PEAP templates does not work with wpa_supplicant-2.6 because of typo MSCHAPv2 vs MSCHAPV2

Bug #1656061 reported by Piotr Karbowski on 2017-01-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned
wicd (Ubuntu)
Undecided
Unassigned

Bug Description

The PEAP templates does not work with wpa_supplicant-2.6, Older version was accepting 'phase2="auth=MSCHAPv2"', The method should be all uppercase. So one needs to replace

    phase2="auth=MSCHAPv2"

with

    phase2="auth=MSCHAPV2"

In both EAP templates to make it working.

Axel Beckert (xtaran) wrote :

Hi,

thanks for the bug report. I'll check if that issue also applies to wicd's Debian package and will try to get it into the next Debian Stable release via wicd's Debian package.

Axel Beckert (xtaran) on 2017-01-22
summary: - PEAP templates does not work with wpa_supplicant-2.6 because of typo .
+ PEAP templates does not work with wpa_supplicant-2.6 because of typo
+ MSCHAPv2 vs MSCHAPV2
Axel Beckert (xtaran) on 2017-01-22
Changed in wicd:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wicd - 1.7.4+tb2-3

---------------
wicd (1.7.4+tb2-3) unstable; urgency=medium

  [ Axel Beckert ]
  * Now maintained by the Debian WICD Packaging Team. (Closes: #801253)
    + Change Vcs-* URLs to …/pkg-wicd/wicd.git
    + Update Maintainers field and add Uploaders field.
  * Add NEWS.Debian entry for changes between Jessie and Stretch
    wrt. /etc/wicd/dhclient.conf.template and the possible need to update
    the file manually.
  * Update dependency on dhcpcd to dhcpcd5. (Closes: #783272) Thanks
    Konrad Zimmermann!
  * Fix typo MSCHAPv2 vs MSCHAPV2 for more pedantic wpa_supplicant 2.6.
    (LP: #1656061) Thanks to Piotr Karbowski for the upstream bug report
    and suggested fix!
  * Add WPA*-PEAP templates without domain. (Closes: #831805, #759785, LP:
    #1591489)
  * Add patch to fix documentation wrt. to which dhclient.conf wicd
    (re)generates. Also update mention path in an older NEWS.Debian item
    to avoid confusion. (Closes: #773809)

  [ Giáp Trần ]
  * Remove $DAEMON_OPTIONS from reload function.

  [ John C. Peterson ]
  * wicd-gtk: Add patch to initialize state of Wifi On/Off button
    properly. (Closes: #758737, LP: #1232521)

  [ Vincent Lefevre ]
  * Add patch to fix wicd-manager-settings.conf(5) man page
    wrt. wired_connect_mode. (Closes: #557156)

 -- Axel Beckert <email address hidden> Sun, 22 Jan 2017 17:16:07 +0100

Changed in wicd (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers