WPA2-PEAP with CCMP/MSCHAPV2 requires Domain this should not be the case

Bug #1591489 reported by Gabryel Mason-Williams on 2016-06-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned
wicd (Debian)
Fix Released
Unknown
wicd (Ubuntu)
Undecided
Unassigned

Bug Description

Version: wicd 1.7.4 (bzr-r961)
Arch Linux

I belive the error is in /etc/wicd/encryption/templates then with in that area so wpa2-peap

name = WPA2-PEAP with CCMP/MSCHAPV2
author = atiketemola
version = 1
require identity *Username domain *Domain password *Password
protected password *Password
-----
ctrl_interface=/var/run/wpa_supplicant
network={
    ssid="$_ESSID"
    proto=RSN
    key_mgmt=WPA-EAP
    pairwise=CCMP
    eap=PEAP
    identity="$_DOMAIN\$_IDENTITY"
    password="$_PASSWORD"
    phase2="auth=MSCHAPv2"
}

sorry if I have missed anything or it is a silly mistake this is my first time reporting a bug

Changed in wicd (Debian):
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wicd (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wicd - 1.7.4+tb2-3

---------------
wicd (1.7.4+tb2-3) unstable; urgency=medium

  [ Axel Beckert ]
  * Now maintained by the Debian WICD Packaging Team. (Closes: #801253)
    + Change Vcs-* URLs to …/pkg-wicd/wicd.git
    + Update Maintainers field and add Uploaders field.
  * Add NEWS.Debian entry for changes between Jessie and Stretch
    wrt. /etc/wicd/dhclient.conf.template and the possible need to update
    the file manually.
  * Update dependency on dhcpcd to dhcpcd5. (Closes: #783272) Thanks
    Konrad Zimmermann!
  * Fix typo MSCHAPv2 vs MSCHAPV2 for more pedantic wpa_supplicant 2.6.
    (LP: #1656061) Thanks to Piotr Karbowski for the upstream bug report
    and suggested fix!
  * Add WPA*-PEAP templates without domain. (Closes: #831805, #759785, LP:
    #1591489)
  * Add patch to fix documentation wrt. to which dhclient.conf wicd
    (re)generates. Also update mention path in an older NEWS.Debian item
    to avoid confusion. (Closes: #773809)

  [ Giáp Trần ]
  * Remove $DAEMON_OPTIONS from reload function.

  [ John C. Peterson ]
  * wicd-gtk: Add patch to initialize state of Wifi On/Off button
    properly. (Closes: #758737, LP: #1232521)

  [ Vincent Lefevre ]
  * Add patch to fix wicd-manager-settings.conf(5) man page
    wrt. wired_connect_mode. (Closes: #557156)

 -- Axel Beckert <email address hidden> Sun, 22 Jan 2017 17:16:07 +0100

Changed in wicd (Ubuntu):
status: Confirmed → Fix Released
Changed in wicd (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.