State of Switch On Wi-Fi button is not consistent (with patch)

Bug #1232521 reported by John C. Peterson on 2013-09-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned
wicd (Debian)
Fix Released
Unknown
wicd (Ubuntu)
Undecided
Unassigned

Bug Description

Version: 1.7.2.4 (wicd-gtk package from Debian Jessie)

The "state" of the "Switch Off/On Wi-Fi" button in the gtk gui is not consistent with the actual power OFF/ON state of the wireless card.

For example, I turned the power state of the wireless card to ON with the Fn+F2 hotkey and verified the state with rfkill. After starting the wicd-gtk gui, the button displayed is "Switch On Wi-Fi" when it should be "Switch Off Wi-Fi" since it's ALREADY powered on!!!

It appeared to me that gui.py should query the power state first and then decide which button to display at start-up.

The attached patch to gui.py worked well for me...

LPNow (lpnow) wrote :

This problem still exsits in 1.7.3 but the patch helps.

There are still two problems I see that need fixing.

1. If you press F2 to enable/disable wifi it would be nice to have wicd immediately show the change with the Switch ON/OFF button changing while wicd is open and you are looking at it, but you only see the new change when you restart wicd.

2. For laptops that the hardware switch is not supported as an example and the end-user maps the F2 key to rfkill to block and unblock the wifi, If you press the wicd Switch On/Off button it will then disable the F2 key mapped to rfkill. So the end-user should be able to press either the button in wicd or F2 and not have them conflict, but at present they conflict with each other...

Axel Beckert (xtaran) on 2017-01-22
tags: added: patch
Changed in wicd (Debian):
status: Unknown → Confirmed

The attachment "Patch for inconsistent state of Switch On Wi-Fi button" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wicd - 1.7.4+tb2-3

---------------
wicd (1.7.4+tb2-3) unstable; urgency=medium

  [ Axel Beckert ]
  * Now maintained by the Debian WICD Packaging Team. (Closes: #801253)
    + Change Vcs-* URLs to …/pkg-wicd/wicd.git
    + Update Maintainers field and add Uploaders field.
  * Add NEWS.Debian entry for changes between Jessie and Stretch
    wrt. /etc/wicd/dhclient.conf.template and the possible need to update
    the file manually.
  * Update dependency on dhcpcd to dhcpcd5. (Closes: #783272) Thanks
    Konrad Zimmermann!
  * Fix typo MSCHAPv2 vs MSCHAPV2 for more pedantic wpa_supplicant 2.6.
    (LP: #1656061) Thanks to Piotr Karbowski for the upstream bug report
    and suggested fix!
  * Add WPA*-PEAP templates without domain. (Closes: #831805, #759785, LP:
    #1591489)
  * Add patch to fix documentation wrt. to which dhclient.conf wicd
    (re)generates. Also update mention path in an older NEWS.Debian item
    to avoid confusion. (Closes: #773809)

  [ Giáp Trần ]
  * Remove $DAEMON_OPTIONS from reload function.

  [ John C. Peterson ]
  * wicd-gtk: Add patch to initialize state of Wifi On/Off button
    properly. (Closes: #758737, LP: #1232521)

  [ Vincent Lefevre ]
  * Add patch to fix wicd-manager-settings.conf(5) man page
    wrt. wired_connect_mode. (Closes: #557156)

 -- Axel Beckert <email address hidden> Sun, 22 Jan 2017 17:16:07 +0100

Changed in wicd (Ubuntu):
status: New → Fix Released
Changed in wicd (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.