wicd daemon calls wpa_supplicant without setting BSSID

Bug #1086573 reported by Takuma Nakajima on 2012-12-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
wicd
Medium
David Paleino

Bug Description

I'm using AirMacExtreme (Mid 2011) and it has two APs with the same ESSID.
When I try to connect to the second AP (XX:XX:XX:XX:XX:5E),
wicd connected to the first AP (XX:XX:XX:XX:XX:5D).

If wicd gets multiple APs with the different BSSID, wicd doesn't select the BSSID.
I checked the source and found the config files for wpa_supplicant in encryption/templates/* .
wicd internally calls wpa_supplicant with the config file created from the templates .

Templates don't include BSSID setting so I added 'bssid=$_BSSID' after 'ssid="$_ESSID"'
to /etc/wicd/encryption/templates/wpa.
After removing /var/lib/wicd/configuration/* (old config files for wpa_supplicant)
and restarting wicd daemon, wicd could connect to the APs with selected BSSID.

# diff -u wpa.orig wpa
--- wpa.orig 2012-12-05 06:29:09.259721491 +0900
+++ wpa 2012-12-05 06:29:50.032515398 +0900
@@ -7,6 +7,7 @@
 ctrl_interface=/var/run/wpa_supplicant
 network={
        ssid="$_ESSID"
+ bssid=$_BSSID
        scan_ssid=$_SCAN
        proto=WPA RSN
        key_mgmt=WPA-PSK

* the version of Wicd
=> 1.7.2.4-r2(portage), 1.7.2.4(GUI)
* Linux distro
=> Gentoo/Linux

David Paleino (dpaleino) wrote :

Hello,

before applying the patch, I need to check whether this breaks the "connect to all networks with this ESSID" feature.

Changed in wicd:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → Medium
assignee: nobody → David Paleino (dpaleino)
milestone: none → 1.7.3
John Boiles (johnaboiles) wrote :

I ran into this today. Took me a while to figure out what was going on.

https://bugs.launchpad.net/wicd/+bug/1245587 is almost certainly a duplicate.

Additionally wicd-curses (and probably all wicd frontends -- see also https://bugs.launchpad.net/wicd/+bug/1037759) doesn't report the correct BSSID as connected. This should probably get fixed at the same time for consistency.

Changed in wicd:
milestone: 1.7.3 → 1.7.4
John Boiles (johnaboiles) wrote :

Here's how I fixed it

koniu (koniu) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers