Unicode error when saving last opened file path

Bug #786755 reported by Steven Sproat on 2011-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Whyteboard
High
Steven Sproat

Bug Description

Whyteboard 0.41.1
Operating System: Windows XP (build 2600, Service Pack 3)
Screen Resolution: 1280x1024
Python Version: 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit (Intel)]
wxPython Version: 2.8.10.1 (msw-unicode)
wxPython Info: (__WXMSW__, wxMSW, unicode, wx-assertions-on, SWIG-1.3.29)
Python Encoding: Default=ascii File=mbcs
wxPython Encoding: utf-8
System Architecture: 32bit x86
Byte order: little
Frozen: windows_exe

 File \"whyteboard\\gui\\frame.pyo\", line 250, in on_save
 File \"whyteboard\\gui\\frame.pyo\", line 274, in on_save_as
 File \"whyteboard\\gui\\frame.pyo\", line 252, in on_save
 File \"whyteboard\\misc\\utility.pyo\", line 146, in save_file
 File \"whyteboard\\misc\\utility.pyo\", line 396, in save_last_path
 File \"whyteboard\\lib\\configobj.pyo\", line 2094, in write
UnicodeEncodeError: \'ascii\' codec can\'t encode characters in position 91-92: ordinal not in range(128)

Steven Sproat (sproaty) on 2011-05-22
Changed in whyteboard:
assignee: nobody → Steven Sproat (sproaty)
importance: Undecided → High
milestone: none → 0.41.2
status: New → Confirmed
Steven Sproat (sproaty) wrote :

Cannot replicate this. May be due to a specific language -- I've added a 'language' attribute to the error report now.

Steven Sproat (sproaty) wrote :

need to test more unicode stuff.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers