Canvas had its area in an invalid state

Bug #786611 reported by Steven Sproat on 2011-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Whyteboard
Medium
Steven Sproat

Bug Description

Whyteboard 0.41.1
Operating System: Windows XP (build 2600, Service Pack 3)
Screen Resolution: 1024x768
Python Version: 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit (Intel)]
wxPython Version: 2.8.10.1 (msw-unicode)
wxPython Info: (__WXMSW__, wxMSW, unicode, wx-assertions-on, SWIG-1.3.29)
Python Encoding: Default=ascii File=mbcs
wxPython Encoding: utf-8
System Architecture: 32bit x86

 File \"whyteboard\\gui\\canvas.pyo\", line 635, in on_paint
 File \"wx\\_windows.pyo\", line 220, in CalcScrolledPosition
TypeError: Expected a 2-tuple of integers or a wxPoint object.

This is Windows-specific as the code only runs on windows.
Failing code:
  relbuf = self.CalcScrolledPosition(self.area)

hmm

Related branches

Steven Sproat (sproaty) wrote :

UNfortunately, this is the only report I've had of this bug, and with such a limited traceback it's hard to see exactly what went wrong to cause the exception. Shame.

this is where logging will help!

Changed in whyteboard:
status: Confirmed → Won't Fix
Steven Sproat (sproaty) wrote :

Found the cause (I think..managed to replicate by doing this)

- open resize dialog
- change canvas size; press apply
- resize canvas, press cancel
- crash happens.

Changed in whyteboard:
status: Won't Fix → Confirmed
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers