whyteboard has no desktop file for main menu

Bug #678114 reported by Marco Clocchiatti on 2010-11-21
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Whyteboard
High
Steven Sproat

Bug Description

whyteboard source code does not contain any desktop file to startup program from main menu.

this because any /usr/share/applications/whyteboard.desktop file exists.
This may it be an example of such a file:

cloc3@aspi2 ~ $ cat /usr/share/applications/whyteboard.desktop
[Desktop Entry]
Version=0.2
Type=Application
Name=Whyteboard
GenericName=Panting App
GenericName[it]=lavagnaDigitale
Comment=Simple whiteboard and PDF annotator.
Exec=whyteboard %U
TryExec=whyteboard
Icon=whcloc3@aspi2 ~ $ cat /usr/share/applications/whyteboard.desktop
[Desktop Entry]
Version=0.2
Type=Application
Name=Whyteboard
GenericName=Panting App
GenericName=lavagna
Comment=Simple whiteboard and PDF annotator.
Exec=whyteboard %U
TryExec=whyteboard
Icon=whyteboard.png
Terminal=false
Categories=GNOME;GTK;Utility;
StartupNotify=true
MimeType=image/png;image/svg+xml;yteboard.png
Terminal=false
Categories=GNOME;GTK;Utility;
StartupNotify=true
MimeType=image/png;image/svg+xml;

an icon in /usr/share/pixmaps/whyteboard.png is also missing.
this one may be good for this:
http://code.google.com/p/whyteboard/logo?cct=1239097979

Marco Clocchiatti (cloc3) wrote :

sorry.

your link is from development branch.
I was speaking about 0.41.1 source code:
http://whyteboard.googlecode.com/files/whyteboard-0.41.1.tar.gz

anyway, if the problem is solved, close this bug.
just give me please a link for a stable source file.
I'm not writing anymore ebuilds for unstable branch because I hate distutils instruments.
:)

Steven Sproat (sproaty) wrote :

Well, that's because the source is the program's source code - unrelated to installing it, I think.

The development branch will usually be the most stable as I fix known bugs and commit there, and release new versions once enough bugs/new stuff have been added; or a really critical bug is fixed.

Due for a new release soon actually, I believe.

Marco Clocchiatti (cloc3) wrote :

ok. my ebuild is fixed to add icon and desktop files without modify 0.41.1 sources.

Steven Sproat (sproaty) on 2011-01-10
Changed in whyteboard:
assignee: nobody → Steven Sproat (sproaty)
Steven Sproat (sproaty) wrote :

For the next release, will ensure the files to build the program as a Python package are included (also test building the program on windows/linux)

Changed in whyteboard:
status: New → Opinion
status: Opinion → Won't Fix
status: Won't Fix → Invalid
status: Invalid → Confirmed
milestone: none → 0.41.2
Steven Sproat (sproaty) wrote :

needs to be done

Changed in whyteboard:
importance: Undecided → High
status: Confirmed → In Progress
upkpk (upkpk) wrote :

Hi sproaty, would you please think about submitting the new version to Debian once the next release is out?
http://packages.debian.org/sid/whyteboard

.desktop launcher and icon needed there! :)

(sorry for hijacking the bug, but I thought it was not worth opening a new one...)

Thank you

Steven Sproat (sproaty) wrote :

Shall do, no problem. I need to get my stuff together and finish the few things holding me back on a release (and laziness!)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers