Error during installation of Whizard alpha v2.8.3

Bug #1855251 reported by Natasa Vukasinovic on 2019-12-05

This bug report was converted into a question: question #686690: Error during installation of Whizard alpha v2.8.3.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
WHIZARD
Undecided
Simon Braß

Bug Description

Dear Whizard authors,

I am trying to install alpha version of Whizard 2.8.3 that Jürgen produced, because resonance histories didn't work with UFO models in Whizard 2.8.2.
Before installation I sourced environment (setup.sh script in attachment), run configure, then make. Compilation stops at vamp directory:

make[1]: Entering directory `/opt/whizard/whizard-2.8.3/build/vamp'
Making all in src
make[2]: Entering directory `/opt/whizard/whizard-2.8.3/build/vamp/src'
Makefile:994: Makefile.depend: No such file or directory
R'[[divisions.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/divisions.nw | divisions.f90
/bin/sh: divisions.f90: command not found
/bin/sh: R[[divisions.f90]]: command not found
make[2]: [divisions.f90] Error 127 (ignored)
R'[[vamp.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/vamp.nw | vamp.f90
/bin/sh: R[[vamp.f90]]: command not found
/bin/sh: vamp.f90: command not found
make[2]: [vamp.f90] Error 127 (ignored)
R'[[tao_random_numbers.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/tao_random_numbers.nw | tao_random_numbers.f90
/bin/sh: R[[tao_random_numbers.f90]]: command not found
/bin/sh: tao_random_numbers.f90: command not found
make[2]: [tao_random_numbers.f90] Error 127 (ignored)
R'[[vamp_stat.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/vamp_stat.nw | vamp_stat.f90
/bin/sh: R[[vamp_stat.f90]]: command not found
/bin/sh: vamp_stat.f90: command not found
make[2]: [vamp_stat.f90] Error 127 (ignored)
R'[[linalg.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/linalg.nw | linalg.f90
/bin/sh: R[[linalg.f90]]: command not found
/bin/sh: linalg.f90: command not found
make[2]: [linalg.f90] Error 127 (ignored)
for src in divisions.f90 vamp.f90 ../../../vamp/src/exceptions.f90 tao_random_numbers.f90 ../../../vamp/src/tao52_random_numbers.f90 ../../../vamp/src/specfun.f90 vamp_stat.f90 ../../../vamp/src/histograms.f90 ../../../vamp/src/utils.f90 linalg.f90 ../../../vamp/src/products.f90; do \
   module="`basename $src | sed 's/\.f[90][0358]//'`"; \
   grep '^ *use ' $src \
     | grep -v '!NODEP!' \
     | sed -e 's/^ *use */'$module'.lo: /' \
           -e 's/, *only:.*//' \
           -e 's/, *&//' \
           -e 's/, *.*=>.*//' \
           -e 's/ *$/.lo/' \
     -e 's/iso_fortran_env\.lo//' ; \
 done > Makefile.depend
grep: divisions.f90: No such file or directory
grep: vamp.f90: No such file or directory
grep: tao_random_numbers.f90: No such file or directory
grep: vamp_stat.f90: No such file or directory
grep: linalg.f90: No such file or directory
make[2]: Leaving directory `/opt/whizard/whizard-2.8.3/build/vamp/src'
make[2]: Entering directory `/opt/whizard/whizard-2.8.3/build/vamp/src'

This loop constantly repeats.
I run make clean, but that doesn't help.

What do you suggest how to resolve this?

Thorsten Ohl (thomega) wrote :

noweb is missing in your build environment:

configure:14248: --- Checks for 'noweb' system ---
configure:14250:
configure:14263: checking for notangle
configure:14296: result: no
configure:14303: checking for cpif
configure:14336: result: no
configure:14343: checking for noweave
configure:14376: result: no

Simon Braß (sbrass) wrote :

Dear Natasa,

if I am correct, you checked out the SVN version of Whizard on hepforge?
If you want to use the SVN version of Whizard, you need noweb in order entangle documentation and source code. There should be package for Debian-based distributions.

However, you can also use our nightly version of Whizard, which is an prepared tar-ball, like you would expect of an "actual" release.

Take a look at: http://whizard.tp.nt.uni-siegen.de/

Cheers,
Simon.

Changed in whizard:
assignee: nobody → Simon Braß (sbrass)
status: New → Invalid

I took nightly build. I run installation on Scientific Linux 6. It indeed, from some reason, doesn't have noweb. When I install noweb Whizard installation finishes successfully.

Without your help I'll never pay attention on that detail during configure execution, because there were no errors.

Valuable experience.
Thank you very much for the help!

Juergen Reuter (j.r.reuter) wrote :

Dear Natasa,
I am a bit confused by your last remark which sounded like the nightly build you took only worked after you installed noweb!? This should not be the case. As Simon explained, the nightly build should work without noweb, while the checkout from our public git or the HepForge svn only work with noweb. Could you confirm that the version which didn't work for you without noweb was not the nightly build?
Cheers,
    JRR (Juergen Reuter)

Changed in whizard:
status: Invalid → New
Juergen Reuter (j.r.reuter) wrote :

This was formerly a bug, but I took the liberty to turn it into a question.

Changed in whizard:
status: New → Invalid

I am sorry because of confusion.
I extracted Whizard package from the archive whizard-2.8.3-2019-11-21-3270322.tar.gz, that I downloaded from http://whizard.tp.nt.uni-siegen.de/.
I thought that this archive is nightly build.

Thank you for resolving my issue.

Juergen Reuter (j.r.reuter) wrote :

This is indeed the nightly built. And this one failed without noweb!?

Juergen Reuter (j.r.reuter) wrote :

I actually just deinstalled noweb on my machine and checked with the (more recent) nightly built
whizard-2.8.3-2019-12-01-1bbe91d.tar.gz
This worked perfectly without noweb. Maybe this was some other problem on your side.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments