JS Error requesting password Reset (in Login Block)in IE9

Reported by Sam I Am on 2012-04-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webtrees
Undecided
Unassigned

Bug Description

This happens from the login block. See http://webtrees.net/en/forums/3-help-for-beta-and-svn-versions/22933-js-error-requesting-password-reset-in-ie9
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0;)
Timestamp: Thu, 12 Apr 2012 22:42:18 UTC

Message: 'checkform' is undefined
Line: 201
Char: 70
Code: 0
URI: www.mydomain.com/webtrees/

In Firefox I see the following in the error console but no error is show to the user (not sure it is related to the above issue):

Timestamp: 4/12/2012 6:44:56 PM
Warning: Use of captureEvents() is deprecated. To upgrade your code, use the DOM 2 addEventListener() method. For more help developer.mozilla.org/en/docs/DOM:element.addEventListener
Source File: www.mydomain.com/webtrees/login.php
Line: 0

Is this still a problem in webtrees 1.3.0? I can't replicate it myself.

Changed in webtrees:
status: New → Incomplete
Sam I Am (samiam) wrote :

Yes, this is still an issue and I can replicate it on your site with IE9. On your home page in IE9, click on the lost password field and try to submit. I do not see the error in IE10 platform preview.

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; OfficeLiveConnector.1.5; OfficeLivePatch.1.3; .NET4.0C)
Timestamp: Fri, 29 Jun 2012 01:13:42 UTC

Message: 'checkform' is undefined
Line: 1
Char: 1
Code: 0
URI: http://www.our-families.info/

Thanks. Fixed - svn 14048

(ps - Sam, I don't mind you testing on my site, but its always best to test on the webtrees DEMO sites. The Latest SVN version will always be the latest code, mine might not be)

Changed in webtrees:
status: Incomplete → Fix Committed
Sam I Am (samiam) wrote :

This is indeed fixed now. The question I have is, why there is no validation at all on the field. You can even submit it with no data entry.

Its not needed, and safer without. If it did validity testing the page could be used to guess/test user names. A genuine user should know their own email address. For the same reason, even submitting a dummy email address results in a valid success message.

Andreas Rauhut (andreas-rauhut) wrote :

So it is not a bug, but a feature, that someone who thought to be already registered, but isn't already, get's the SUCCESS message when he tries to request a password?

Yes. Did you not understand #5?

fisharebest (fisharebest) wrote :

Fix released in webtrees 1.3.1

Changed in webtrees:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers