Interactive tree url wrong after login

Bug #920405 reported by Muadh Hamidaddin on 2012-01-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webtrees
Fix Released
Medium
fisharebest

Bug Description

webtrees-svn at http://webtrees.net/webtrees-svn

While as a visitor in interactive tree page at:
http://webtrees.net/webtrees-svn/module.php?mod=tree&mod_action=treeview&ged=kennedy.ged&rootid=I001
clicking Login, logging in page displays, then after logging in, a different url is given to get back to the interactive tree page.
http://webtrees.net/webtrees-svn/module.php?mod=tree&mod_action=treeview&ged=kennedy.ged&rootid=I001
that displays blank page in chrome and page not found in IE.

fisharebest (fisharebest) wrote :

This affects all URLS that contain "&".

We use the get_query_url() function, which is designed to produce an escaped URI for use in HTML.

Since we use this as a redirect, we need an absolute and unescaped URI.

Perhaps something like

rawurlencode(WT_SERVER_NAME.WT_SCRIPT_PATH.WT_SCRIPT_NAME.$_SERVER['QUERY_STRING']);

We generate these links in (at least) two places. login_link() and WT_Controller_Base.

Changed in webtrees:
assignee: nobody → fisharebest (fisharebest)
importance: Undecided → Medium
status: New → Triaged
fisharebest (fisharebest) wrote :

Fixed in SVN.

The function get_query_url() now takes an additional parameter: '&' for HTML and '&' for JavaScript and HTTP redirection

Changed in webtrees:
status: Triaged → Fix Committed
fisharebest (fisharebest) wrote :

Fix released in 1.3.0

Changed in webtrees:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers