AP tests for the container stall/freeze

Bug #1449660 reported by Alexandre Abreu on 2015-04-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
High
Alexandre Abreu
1.7
Undecided
Unassigned
webapps-sprint
High
Alexandre Abreu
webbrowser-app
Invalid
Critical
Alexandre Abreu

Bug Description

At least when using oxide 1.7.3, AP tests for the container on a vivid desktop stall/freeze after having apparently executed properly and w/o errors.

Changed in webbrowser-app:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
status: New → In Progress
David Barth (dbarth) on 2015-04-29
Changed in webapps-sprint:
milestone: none → sprint-8
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
status: New → In Progress
Olivier Tilloy (osomon) wrote :

I’m still seeing that with oxide 1.7.6 (currently in silo 28).

Changed in webbrowser-app:
importance: High → Critical
Olivier Tilloy (osomon) wrote :

Bumping the priority as this prevents CI runs on every single webbrowser-app merge request from running to completion.

Olivier Tilloy (osomon) wrote :

Just reproduced on arale, I attached gdb to the stalled webapp-container process, sent it SIGSEGV and got a full stacktrace for all threads which I’m attaching here, in the hope that it might be useful for identifying the cause of the issue.

Thank you Olivier,

the stacktrace is not really meaningful though. I am able to repro at will on the desktop w/ any version > 1.7.3, and I closing on the issue,

Changed in oxide:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
status: New → In Progress
David Barth (dbarth) on 2015-04-30
Changed in webapps-sprint:
milestone: sprint-8 → sprint-9
Changed in oxide:
milestone: none → branch-1.8
status: In Progress → Fix Released
Changed in webbrowser-app:
status: In Progress → Invalid
Changed in webapps-sprint:
status: In Progress → Invalid
David Barth (dbarth) on 2015-05-19
Changed in webapps-sprint:
status: Invalid → Fix Committed
David Barth (dbarth) on 2015-05-26
Changed in webapps-sprint:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments