Selection tests fail against oxide trunk

Bug #1434193 reported by Michael Sheldon on 2015-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webbrowser-app
Fix Released
Medium
Olivier Tilloy
webbrowser-app (Ubuntu)
Undecided
Olivier Tilloy

Bug Description

Three selection tests fail when run against oxide trunk because the selection area now runs off the edge of the screen.

The failing tests are:

webbrowser_app.tests.test_selection.TestSelection.test_resize_selection
webbrowser_app.tests.test_selection.TestSelection.test_cancel_selection
webbrowser_app.tests.test_selection.TestSelection.test_copy_selection

Logs and a video of the failed tests are attached.

Related branches

Olivier Tilloy (osomon) wrote :

It appears that with oxide’s latest viewport changes, the test page for selection is initially zoomed in. As a result the div that is supposed to be centered on screen is not, and the assumptions made in the tests are rendered invalid.

Modifying the test page to add the following meta tag fixes it:

    <meta name="viewport" content="initial-scale=1">

Changed in webbrowser-app:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Olivier Tilloy (osomon)
Chris Coulson (chrisccoulson) wrote :

This shouldn't be an issue just in trunk - it should be there in 1.5 as well because it's due to the fix for bug 1402975 (at least, I think it is).

Basically, when running on mobile we set a layout viewport with of 960px for pages that don't have a viewport meta tag so that desktop sites are laid out better (this is the same as Chrome/Android). The issue with the test is that it creates an absolute positioned element which is positioned relative to the layout viewport, and the layout viewport != device viewport. This is the expected behaviour

Olivier Tilloy (osomon) on 2015-03-20
Changed in webbrowser-app:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.04.20150323-0ubuntu1

---------------
webbrowser-app (0.23+15.04.20150323-0ubuntu1) vivid; urgency=medium

  [ Olivier Tilloy ]
  * Discard selection when navigating away. (LP: #1433503)
  * Expose the SearchEngine type to QML.
  * Remove workaround for bug #1377198, which was fixed in oxide 1.5.
    (LP: #1377198)
  * Rename test helper function from clear_cache() to clear_datadir(),
    to better reflect what it really does.
  * Update the 'selection' test page to hopefully fix the failing
    autopilot test on mako. (LP: #1434193, #1433020)
  * Update translation template.
  * Use the loadEvent signal (introduced in oxide 1.3).
 -- CI Train Bot <email address hidden> Mon, 23 Mar 2015 07:49:27 +0000

Changed in webbrowser-app (Ubuntu):
status: New → Fix Released
Olivier Tilloy (osomon) on 2015-03-27
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Changed in webbrowser-app:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers