autoscrolling not working in online accounts

Bug #1413765 reported by Bill Filler
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Online Accounts setup for Ubuntu Touch
High
Alberto Mardegan
webbrowser-app
Invalid
High
Olivier Tilloy
ubuntu-system-settings-online-accounts (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu RTM)
Undecided
Alberto Mardegan

Bug Description

krillin rtm build 208

clicking in entry field in an online accounts embedded webpage is not causing the field to scroll into view as it does when loading in webbrowser-app

Steps to reproduce:
- create a new Google online account
- click on the username/email field
- the OSK is displayed

Expected result:
- the entry field that has focus should be scrolled into view and unobstructed

Actual result:
- the entry field is not scrolled and partially obstructed

This same thing works when done directly in the browser. Not sure if the issue is browser related, or something to do with the container.

Bill Filler (bfiller)
Changed in ubuntu-system-settings-online-accounts:
importance: Undecided → High
assignee: nobody → Alberto Mardegan (mardy)
Changed in webbrowser-app:
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon)
Changed in webbrowser-app:
status: New → Invalid
Revision history for this message
Olivier Tilloy (osomon) wrote :

I can confirm the issue on krillin image #209.

I had a quick look at the code, and the webview is inside a Loader whose anchors are defined like so:

    Loader {
        anchors {
            bottom: cancelButton.top
            bottomMargin: Math.max(osk.height - cancelButton.height, 0)
        }
    }

If I remove the bottomMargin, and bind the bottom anchor to osk.top, the field is scrolled into view as expected. So somehow the bottomMargin is causing oxide to not be notified of the height change in time.

This should be easy enough to fix by making the bottom anchor conditional (depending on the OSK’s visibility), or by making both the OSK and cancel button children of an item and anchoring the webview to that item.

Changed in ubuntu-system-settings-online-accounts:
status: New → Confirmed
Revision history for this message
Alberto Mardegan (mardy) wrote :

Thanks for the hint, Olivier! That seems to be working. :-)

Changed in ubuntu-system-settings-online-accounts:
status: Confirmed → In Progress
Bill Filler (bfiller)
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Fix Released
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww07-2015
status: New → Confirmed
Alberto Mardegan (mardy)
Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
assignee: nobody → Alberto Mardegan (mardy)
status: New → In Progress
Alberto Mardegan (mardy)
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.5+15.04.20150205~rtm-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.5+15.04.20150205~rtm-0ubuntu1) 14.09; urgency=medium

  [ Alberto Mardegan ]
  * Anchor the webview directly to the OSK (LP: #1413765)
 -- Ubuntu daily release <email address hidden> Thu, 05 Feb 2015 14:41:22 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Alberto Mardegan (mardy)
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers