[webapp-container] reload() does not work

Bug #1309138 reported by Alexandre Abreu on 2014-04-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
webbrowser-app
Fix Released
High
Alexandre Abreu
webbrowser-app (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

When in the webapp-container and the "network problem" dialog appears, the reload button does not work and trigger a reload.

A user is then unable to reload the page when the network issue is gone.

[Test Case]

- make sure that you are not connected to the network
- open a webapp (on touch or desktop)
- the network problem dialog should appear
- put back the network
- click on the 'reload' button
- the target webpage should appear

[Regression Potential]

None

Related branches

description: updated
Changed in webbrowser-app:
status: New → In Progress
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
Robert Bruce Park (robru) wrote :

This is fixed by 0.23+14.04.20140422-0ubuntu1 which is currently in UNAPPROVED.

Hello Alexandre, or anyone else affected,

Accepted webbrowser-app into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/webbrowser-app/0.23+14.04.20140422-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in webbrowser-app (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Dave Morley (davmor2) wrote :

I have verified that the fix actually does display a webpage on reconnection to the network. However the page that is bought up on the whole is the desktop page and not the mobile version. I'm assuming the UA isn't resent on page refresh.

David Barth (dbarth) wrote :
Dave Morley (davmor2) wrote :

Bug above has been listed in bug #1313686 so with that I have mark this as verification-done

tags: added: verification-done
removed: verification-needed
David Barth (dbarth) on 2014-04-30
Changed in webbrowser-app:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed

The verification of the Stable Release Update for webbrowser-app has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+14.04.20140422-0ubuntu1

---------------
webbrowser-app (0.23+14.04.20140422-0ubuntu1) trusty; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Alexandre Abreu ]
  * Fix the network dialog reload (LP: #1309138)
  * Oxide (and Chromium) does not inform of non user driven navigations
    (or more specifically redirects that would be part of an
    popup/webview load (after its been granted). Quite a few sites (e.g.
    Youtube), create popups when clicking on links (or following a
    window.open()) with proper youtube.com address but w/ redirection
    params, e.g.:
    http://www.youtube.com/redirect?q=http%3A%2F%2Fgodzillamovie.com%2F&
    redir_token=b8WPI1pq9FHXeHm2bN3KVLAJSfp8MTM5NzI2NDg3NEAxMzk3MTc4NDc0
    In this instance the popup & navigation is granted, but then a
    redirect happens inside the popup to the real target url (here
    http://godzillamovie.com) which is not trapped by a navigation
    requested and therefore not filtered. The only way to do it atm is
    to listen to url changes in popups & also filter there. (LP:
    #1294279)
 -- Ubuntu daily release <email address hidden> Tue, 22 Apr 2014 16:55:41 +0000

Changed in webbrowser-app (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers