[webapp-container] Facebook app appears to open links in a new tab, rather than external browser window or popup windows

Bug #1294279 reported by Michael Hall on 2014-03-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webbrowser-app
Fix Released
High
David Barth
webbrowser-app (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

On Desktop, when the user clicks on a link that is supposed to open a new popup (target="_blank" or window.open), the link does not open properly (no popup or invalid url not part the the same domain as the webapp).

[Test Case]

- On Desktop:

1. Open the Facebook webapp,
2. Click on an *outside* link (that is supposed to be opened outside the facebook page),
3. Make sure that it opens in the main browser,
4. Open the GooglePlus webapp,
5. Click on an outside link,
6. Make sure that it opens in the browser,
7. Go to Youtube,
8. Search for a video that has links to a page outside of youtube (e.g. "movie trailers" with links to movie pages in the 'description'),
9. Once in the video page, click on the movie webpage link, it should open in the external browser,

- On UbuntuTouch: the webapp-container does not create or handle popups, it should delegate opened links to the webbrowser-app instead,

[Regression Potential]

Handling of popups

Related branches

Michael Hall (mhall119) on 2014-03-18
Changed in webbrowser-app:
assignee: nobody → David Barth (dbarth)
David Barth (dbarth) on 2014-03-18
tags: added: webapps-blocker
Changed in webbrowser-app:
importance: Undecided → High
milestone: none → 14.04
David Barth (dbarth) wrote :

Were you opening the webapp in chromium or in the new qtwebkit container? ie did you have ~/.local/share/unity-webapps/enable-webapp-container ?

Also, can you specify the version of unity-webapps-service you were running;?

David Barth (dbarth) wrote :

ahem... on touch. I can't reproduce that with image #237. Were you trying to open particular links on facebook? Can you forward me one of those?

David Barth (dbarth) on 2014-04-08
Changed in webbrowser-app:
status: New → In Progress
David Barth (dbarth) wrote :

That particular popup redirect issue has been fixed and landed. However, bug 1307735 made it worse.

Changed in webbrowser-app:
status: In Progress → Fix Committed
Changed in webbrowser-app:
status: Fix Committed → In Progress
summary: [webapp-container] Facebook app appears to open links in a new tab,
- rather than external browser window
+ rather than external browser window or popup windows
description: updated
Robert Bruce Park (robru) wrote :

This is fixed by 0.23+14.04.20140422-0ubuntu1 which is currently in UNAPPROVED.

Hello Michael, or anyone else affected,

Accepted webbrowser-app into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/webbrowser-app/0.23+14.04.20140422-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in webbrowser-app (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
David Barth (dbarth) wrote :

I verified the bug fix again by navigating to my facebook wall and opening links to articles or sites that were obviously not Facebook content. The container did open the links with the default browser, as intended.

I will keep the verification-needed tag for now, to let testers outside of our development group verify this fix.

Changed in webbrowser-app:
status: In Progress → Fix Committed
Changed in webbrowser-app (Ubuntu):
status: New → Fix Committed
Dave Morley (davmor2) wrote :

Verified that all link types are now working in twitter/facebook/gmail/google+

I'm assuming that will mean they work anywhere.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for webbrowser-app has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+14.04.20140422-0ubuntu1

---------------
webbrowser-app (0.23+14.04.20140422-0ubuntu1) trusty; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Alexandre Abreu ]
  * Fix the network dialog reload (LP: #1309138)
  * Oxide (and Chromium) does not inform of non user driven navigations
    (or more specifically redirects that would be part of an
    popup/webview load (after its been granted). Quite a few sites (e.g.
    Youtube), create popups when clicking on links (or following a
    window.open()) with proper youtube.com address but w/ redirection
    params, e.g.:
    http://www.youtube.com/redirect?q=http%3A%2F%2Fgodzillamovie.com%2F&
    redir_token=b8WPI1pq9FHXeHm2bN3KVLAJSfp8MTM5NzI2NDg3NEAxMzk3MTc4NDc0
    In this instance the popup & navigation is granted, but then a
    redirect happens inside the popup to the real target url (here
    http://godzillamovie.com) which is not trapped by a navigation
    requested and therefore not filtered. The only way to do it atm is
    to listen to url changes in popups & also filter there. (LP:
    #1294279)
 -- Ubuntu daily release <email address hidden> Tue, 22 Apr 2014 16:55:41 +0000

Changed in webbrowser-app (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in webbrowser-app (Ubuntu):
status: Fix Committed → Fix Released
Bill Filler (bfiller) on 2014-05-28
Changed in webbrowser-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers