Touch events leak with the on-screen keyboard

Bug #1235328 reported by David Barth
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webbrowser-app
Fix Released
High
Olivier Tilloy
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

This is a follow-up bug to https://bugs.launchpad.net/ubuntu/+source/ubuntu-keyboard/+bug/1233207

The keyboard layout issue has been fixed, but there are still problems to login with U1.

Further analysis showed that there are 2 remaining problems:
1. the css of the login page provides a layout not adapted to the screen size of the device
2. this erroneous layout forces the web view and OSK into a situation where touch evens "leak" into the webview, whereas they should stay and be synthesized within the OSK region

#1 is being addressed, but #2 still seems interesting to fix, in case other web sites exhibit the same layout problem.

Related branches

Revision history for this message
Olivier Tilloy (osomon) wrote :

It appears #2 is a bug in the UITK, for which I filed bug #1236360. I’ll close this one as invalid.

Changed in webbrowser-app:
status: New → Invalid
Revision history for this message
Olivier Tilloy (osomon) wrote :

I was too prompt to discard this bug as invalid. As it turns out, the browser doesn’t use the anchorToKeyboard property of the MainView component, it re-implements it. Both implementations are very similar though, and as a result are affected by the same bug, but it has to be fixed both in the UITK and in the browser itself.

Changed in webbrowser-app:
status: Invalid → Confirmed
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon)
Changed in webbrowser-app:
status: Confirmed → In Progress
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:webbrowser-app at revision 376, scheduled for release in webbrowser-app, milestone ubuntu-13.04-month-5

Changed in webbrowser-app:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.22+13.10.20131007.2-0ubuntu1

---------------
webbrowser-app (0.22+13.10.20131007.2-0ubuntu1) saucy; urgency=low

  [ Alexandre Abreu ]
  * Handle URL open requests and expose a org.freedesktop.Application
    interface on DBUS. (LP: #1230404)

  [ David Barth ]
  * UA overrides for google domains, youtube, twitter. Also
    login.ubuntu.com. (LP: #1233270)

  [ Olivier Tilloy ]
  * Hide the activity view when validating the address bar. (LP:
    #1234843)
  * Reverted revision 343: now all domains expand consistently in the
    activity view, even if they contain only one entry. (LP: #1235137)
  * Better UA override rule for mobile twitter (don’t pretend to be an
    android). Thanks Adnane Belmadiaf for the tip!. (LP: #1233270)
  * Fix the height of the webview container when in landscape
    orientation. (LP: #1235328, #1234949)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 376
 -- Ubuntu daily release <email address hidden> Mon, 07 Oct 2013 21:30:43 +0000

Changed in webbrowser-app (Ubuntu):
status: New → Fix Released
Olivier Tilloy (osomon)
Changed in webbrowser-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers