[browser] touch target for back button is too small

Reported by Lina Pio on 2013-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Lina Pio
webbrowser-app
High
Olivier Tilloy
webbrowser-app (Ubuntu)
High
Olivier Tilloy
Saucy
High
Olivier Tilloy

Bug Description

Current situation
Touch target for back button is too small - particularly when user ends up on the 'data network error' page - the back button doesn't activate at first on second tap it takes the user back two pages back in the history instead of taking the user back to the most recently viewed page.

Desired solution
Touch target is bigger and is more sensitive to touch - takes the user back one page at a time only.

Related branches

lp:~osomon/webbrowser-app/toolbar-spacing
Merged into lp:webbrowser-app at revision 338
Günter Schwann (community): Approve on 2013-09-24
PS Jenkins bot: Approve (continuous-integration) on 2013-09-24
Lina Pio (linapio) on 2013-09-11
Changed in webbrowser-app:
assignee: nobody → Olivier Tilloy (osomon)
Lina Pio (linapio) on 2013-09-11
tags: added: browser-app-august-2013
Lina Pio (linapio) on 2013-09-11
Changed in ubuntu-ux:
assignee: nobody → Lina Pio (linapio)
importance: Undecided → Critical
importance: Critical → High
status: New → Fix Committed
Bill Filler (bfiller) on 2013-09-20
Changed in webbrowser-app:
status: New → Triaged
Changed in webbrowser-app (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in webbrowser-app:
importance: Undecided → High
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
milestone: none → ubuntu-13.10
Olivier Tilloy (osomon) wrote :

I verified that the back button has the same dimensions as the other chrome buttons (forward and activity): 5×5 grid units.
As far as I know, that’s also the default dimensions of standard toolbar buttons in other applications.
The only difference is the left margin, which in the browser is 1 grid unit, and in the default toolbar for other applications is 2 grid units. I’ll make it 2 grid units for consistency, and I suspect this will fix the problem.

Changed in webbrowser-app:
status: Triaged → In Progress
Olivier Tilloy (osomon) on 2013-09-24
Changed in webbrowser-app (Ubuntu Saucy):
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:webbrowser-app at revision 338, scheduled for release in webbrowser-app, milestone ubuntu-13.04-month-5

Changed in webbrowser-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.22+13.10.20130926.1-0ubuntu1

---------------
webbrowser-app (0.22+13.10.20130926.1-0ubuntu1) saucy; urgency=low

  [ daker ]
  * Added support for confirm dialogs. (LP: #1169758)
  * Added support for Prompt dialogs. (LP: #1169759)

  [ Adnane Belmadiaf ]
  * Added support for confirm dialogs. (LP: #1169758)
  * Added support for Prompt dialogs. (LP: #1169759)

  [ Alexandre Abreu ]
  * The application name is being set from the APP_ID during the init
    phase of the webbrowser app but it is later being overwritten
    because of the applicationName property in the browser MainView. One
    option could be to get rid of the applicationName property update
    altogether but it is being used by the MainView to update the domain
    for the i18n plugin which is itself flawed in a way since it does
    not fallback on the Qtcore::applicationName but requires the
    applicationName property of a MainView to be set explicitely. . (LP:
    #1229942)

  [ Olivier Tilloy ]
  * When the activity view cannot be found, return None instead of
    raising an exception, as that’s what tests expect.
  * Contextual menus with specific actions for links and images when
    they are long-pressed.
  * Fix dependencies alignment in debian/control.
  * Adjust margins in the chrome to be consistent with the default
    toolbar. (LP: #1223946)
  * New assets and visual tweaks for the expanded activity view. (LP:
    #1223952)
  * Updated translation template.
  * Go directly to the entry instead of expanding the timeline view when
    there is only one entry for a given domain. This change has been
    requested by design.
  * Very basic support for ini-style read-only settings. This is a
    temporary solution until Settings support lands in the SDK. At the
    moment, only the default homepage can be customized. To change the
    default homepage, one can write the following line to
    ~/.config/webbrowser-app/settings.conf:     homepage =
    http://example.org.
  * Match domains for overriding the UA string by starting from the full
    domain name, and iterating down to the TLD. This ensures that if
    there is an override rule for "b.a.c", it will get precedence over
    another existing rule for "a.c".

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 346
 -- Ubuntu daily release <email address hidden> Thu, 26 Sep 2013 08:47:31 +0000

Changed in webbrowser-app (Ubuntu Saucy):
status: In Progress → Fix Released
Olivier Tilloy (osomon) on 2013-09-27
Changed in webbrowser-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers