Clicking a link in a webapp should open the site in the browser

Bug #1187917 reported by Pat McGowan
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
webbrowser-app
Fix Released
Medium
Alexandre Abreu
webbrowser-app (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

A good example is the gmail app. If a message contains a url, clicking it loads in the same window rather than the browser app.
This would greatly improve usability if it could be done near term.

Tags: dogfood

Related branches

Changed in webbrowser-app:
assignee: Olivier Tilloy (osomon) → Alexandre Abreu (abreu-alexandre)
Revision history for this message
Olivier Tilloy (osomon) wrote :

Since a recent revision in trunk (not released in daily images yet), links will now be opened in a new tab. However this is not much better, since in webapp mode there is no chrome, hence no way to switch between open tabs.

Revision history for this message
Olivier Tilloy (osomon) wrote :

See related bug #1186556 (Browser does not respond to Qt.openUrlExternally(link)).

Changed in webbrowser-app:
status: New → Confirmed
Revision history for this message
Alexandre Abreu (abreu-alexandre) wrote :

Pending on release of a qtwebkit build with the patch I pushed upstream (& approved):

https://bugs.launchpad.net/ubuntu/+source/qtwebkit-opensource-src/+bug/1217683

Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:webbrowser-app at revision 305, scheduled for release in webbrowser-app, milestone ubuntu-13.04-month-5

Changed in webbrowser-app:
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.22+13.10.20130918.1-0ubuntu1

---------------
webbrowser-app (0.22+13.10.20130918.1-0ubuntu1) saucy; urgency=low

  [ Alexandre Abreu ]
  * chrome selection.
  * Navigation support. (LP: #1187917)
  * Handle window raise event from webapps. The event might be occur for
    example when the app is being raised from the messaging menu etc.
    And additional proxy object is used to give access from the qml
    browser back to the native window object.
  * Add a command line argument for webapps that allows one to specify
    the root path for installed webapp searches. The uses cases are
    multiple, among other things local testing, and click packages
    (where webapps are installed in /opt/) and should be looked up
    there. For click webapps, the desktop-click hook will set the CWD
    when starting the app to the local click app folder and aa_exec will
    make sure that all is properly setup. Given the containment rules
    for click apps, the webbrowser-app should be told where to look for
    the webapp content (javascript snippet) and not follow the usual
    desktop rules (and the Exec line from the webapp desktop file should
    explicitly specify where to look for it based on CWD). .
  * Tweak title to remove the ubuntu browser references when run as a
    webapp.

  [ daker ]
  * Added support for IP adresses. (LP: #1166063)

  [ Olivier Tilloy ]
  * Temporarily skip a test that consistently fails on devices. This is
    to unblock autolanding of a large number of valid merge requests
    that have been sitting there for too long.
  * Remove unused runtime dependency on qtdeclarative5-hud1.0. It had
    crept back in by accident at revision 242. (LP: #1221344)
  * Skip a test that is flaky (for a known reason) on slow
    configurations.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 312
 -- Ubuntu daily release <email address hidden> Wed, 18 Sep 2013 08:02:09 +0000

Changed in webbrowser-app (Ubuntu):
status: Confirmed → Fix Released
Olivier Tilloy (osomon)
Changed in webbrowser-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers