webapp will fail to start after following external link in webbrowser-app

Bug #1597384 reported by Mathijs Veen on 2016-06-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Webapps-core project
High
Alexandre Abreu
webapps-sprint
High
Alexandre Abreu

Bug Description

device: bq-aquaris m10 tablet (frieza)
os: ubuntu 15.04 OTA-11

steps to reproduce:
1) start fb webapp and click an external link for instance a youtube link.
The links opens of course within the webapp oxide container; not the webbrowser-app itself.

2) Then, in the upper right corner, use the icon to break out of the webapp and continue viewing the link in the actuall webbrowser-app. Then stop/kill the webbrowser app by swiping it up or down in the carousel.

3) Start the facebook webapp again. it hangs on the spinner indefinitely. retrying is no use. Only a reboot (or presumably a clearing of app cache) can fix this.

these steps are reproducible 100%

i will try and add a video to show the steps.

Changed in webapps-core:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
David Barth (dbarth) on 2016-06-30
Changed in webapps-sprint:
milestone: none → sprint-24
assignee: nobody → Alexandre Abreu (abreu-alexandre)
status: New → Triaged
importance: Undecided → High
Changed in webapps-core:
importance: Undecided → High
status: New → Triaged
Changed in webapps-sprint:
status: Triaged → In Progress
Changed in webapps-core:
status: Triaged → In Progress

Thank you for the video, I haven't been able to repro it on an MX4 or BQ, but it seems like an instance of https://code.launchpad.net/~abreu-alexandre/oxide/fix-crash-scroll-message-handler/+merge/292321

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers