Cannot share content to facebook/twitter, the webapp opens to homepage instead of new post screen

Bug #1564770 reported by TarotChen on 2016-04-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
The Webapps-core project
High
Alexandre Abreu
unity-webapps-qml
High
Alexandre Abreu
webapps-sprint
High
Alexandre Abreu

Bug Description

Test Environment:
current build number: 296
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2016-03-28 10:43:35
version version: 296
version ubuntu: 20160326
version device: 20160323-1467d3c
version custom: 20160324--36-54-vivid

Steps:
1.Twitter account set up in ubuntu-system-settings online accounts
2.Open Gallery app
3.Select a photo, tap on menu and share
4.Tap to share in Twitter
5.Observe the result

Actual result:
Twitter webapp opens to homepage instead of new post screen

Expected result:
Twitter webapp is opened to new post screen, selected photo is displayed and attached to the post.

Related branches

David Barth (dbarth) wrote :

Sounds like a regression due to some API calls involved.

Changed in webapps-sprint:
milestone: none → sprint-21
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Changed in webapps-core:
assignee: nobody → Alexandre Abreu (abreu-alexandre)

Also happens on Arale r283

Changed in webapps-core:
status: New → Confirmed
importance: Undecided → High
Changed in webapps-sprint:
importance: Undecided → High
status: New → Confirmed
David Barth (dbarth) on 2016-04-07
Changed in canonical-devices-system-image:
assignee: nobody → David Barth (dbarth)
status: New → Confirmed
milestone: none → 11
David Barth (dbarth) on 2016-04-26
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in webapps-core:
status: Confirmed → In Progress
Changed in webapps-sprint:
status: Confirmed → In Progress
milestone: sprint-21 → sprint-22
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in webapps-core:
status: In Progress → Fix Committed
Changed in webapps-sprint:
status: In Progress → Fix Committed
Changed in unity-webapps-qml:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Changed in canonical-devices-system-image:
importance: Undecided → High
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers