When a trusted session is active webapps will not start

Bug #1441873 reported by Pat McGowan on 2015-04-08
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
David Barth
Online Accounts setup for Ubuntu Touch
Critical
Alberto Mardegan
The Webapps-core project
Critical
Alberto Mardegan
Ubuntu Translations
Undecided
Unassigned
webapps-sprint
Critical
Alberto Mardegan
webbrowser-app
Invalid
Critical
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu)
Undecided
Unassigned
webbrowser-app (Ubuntu)
Critical
Alberto Mardegan

Bug Description

RequestAccess failed: QDBusError("com.ubuntu.OnlineAccountsUi.NoPromptSession", "Could not create a prompt session")

A webapp was open with a trusted session. Starting other webapps results in them silently closing without any message to the user.

Related branches

Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → David Barth (dbarth)
milestone: none → ww15-2015
Alberto Mardegan (mardy) wrote :

I cannot reproduce this with image 166. It may be that there was another trusted session active; if that's the case, it's not possible to create another one, currently.
It's a limitation in Mir, so I was told.

David Barth (dbarth) wrote :

You can easily reproduce if you try to launch 2 webapps, each trying to create their own account with OA. ie:
- remove Twitter and Facebook accounts
- start Twitter, let it open the trust prompt; then switch to the app scope
- start Facebook: it will quit immediately and that error message can be seen in the logs

This is an error case that should be handled with more indications for the user.

summary: - Twitter and gmail not working on vivid
+ When a trusted session is active webapps will not start
description: updated
Changed in ubuntu-system-settings-online-accounts:
assignee: nobody → Alberto Mardegan (mardy)
Changed in webapps-core:
assignee: Alexandre Abreu (abreu-alexandre) → Alberto Mardegan (mardy)
Changed in canonical-devices-system-image:
milestone: ww15-2015 → ww17-2015
David Barth (dbarth) on 2015-04-14
Changed in webapps-sprint:
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → Critical
status: New → Confirmed
milestone: none → sprint-8
Changed in canonical-devices-system-image:
milestone: ww17-2015 → ww21-2015
David Barth (dbarth) on 2015-04-30
Changed in webapps-sprint:
milestone: sprint-8 → sprint-9
Alberto Mardegan (mardy) on 2015-05-13
Changed in ubuntu-system-settings-online-accounts:
status: New → In Progress
importance: Undecided → Medium
Changed in webbrowser-app:
status: New → In Progress
importance: Undecided → Critical
Changed in ubuntu-system-settings-online-accounts:
importance: Medium → Critical
Changed in webbrowser-app:
assignee: nobody → Alberto Mardegan (mardy)
David Barth (dbarth) on 2015-05-19
Changed in webapps-sprint:
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
David Barth (dbarth) on 2015-05-27
Changed in webapps-sprint:
status: In Progress → Fix Committed
Changed in webapps-core:
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in webbrowser-app:
status: In Progress → Fix Committed
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Committed
Olivier Tilloy (osomon) on 2015-06-08
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → Critical
status: New → In Progress
Changed in webbrowser-app:
assignee: Alberto Mardegan (mardy) → nobody
status: Fix Committed → Invalid
David Barth (dbarth) on 2015-06-10
Changed in webapps-sprint:
milestone: sprint-9 → sprint-10
Changed in canonical-devices-system-image:
milestone: ww21-2015 → ww26-2015
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.6+15.10.20150624-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.6+15.10.20150624-0ubuntu1) wily; urgency=medium

  [ Alberto Mardegan ]
  * Fix build with Qt 5.5 (LP: #1387537, #1421009, #1448878, #1447175)
  * Return the error name to the client (LP: #1441873)

  [ CI Train Bot ]
  * New rebuild forced.

 -- CI Train Bot <email address hidden> Wed, 24 Jun 2015 13:36:39 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.10.20150624-0ubuntu1

---------------
webbrowser-app (0.23+15.10.20150624-0ubuntu1) wily; urgency=medium

  [ Alberto Mardegan ]
  * Show an error screen if the trust session could not be opened. (LP:
    #1441873)

  [ CI Train Bot ]
  * New rebuild forced.
  * Resync trunk.

  [ Olivier Tilloy ]
  * Update translation template.

 -- CI Train Bot <email address hidden> Wed, 24 Jun 2015 13:37:10 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
David Barth (dbarth) wrote :

The webbrowser-app changes require translation strings updates. I added an ubuntu-translations reference to the project list to that end.

Changed in canonical-devices-system-image:
milestone: ww26-2015 → ww28-2015
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2015-09-14
Changed in ubuntu-system-settings-online-accounts:
status: Fix Committed → Fix Released
Changed in webapps-sprint:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers