GMail app crashes on start up

Bug #1339724 reported by Michael Sheldon on 2014-07-09
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
The Webapps-core project
Critical
Unassigned
apparmor-easyprof-ubuntu (Ubuntu)
High
Jamie Strandboge
webapps-demo (Ubuntu)
Undecided
Unassigned

Bug Description

Image: r121

With Oxide 1.1.0~bzr640-0ubuntu1

When starting the GMail app it redirects through a couple of the normal authentication pages and then crashes prior to displaying the inbox. The syslog shows that apparmor rejected a 'file_receive' operation immediately prior to the crash:

Jul 9 13:50:48 ubuntu-phablet kernel: [ 9243.152387] type=1400 audit(1404913848.763:135): apparmor="DENIED" operation="file_receive" profile="com.ubuntu.developer.webapps.webapp-gmail_webapp-gmail_1.0.12//oxide_helper" name="/home/phablet/.local/share/com.ubuntu.developer.webapps.webapp-gmail/databases/https_mail.google.com_0/1" pid=20410 comm="Chrome_ChildIOT" requested_mask="rw" denied_mask="rw" fsuid=32011 ouid=32011

Also, starting the application outside of containment allows it to work correctly.

description: updated
Olivier Tilloy (osomon) on 2014-07-09
Changed in webbrowser-app:
importance: Undecided → Critical
status: New → Confirmed
Changed in webbrowser-app:
importance: Critical → High
Changed in webbrowser-app:
importance: High → Critical
Olivier Tilloy (osomon) wrote :

/home/phablet/.local/share/com.ubuntu.developer.webapps.webapp-gmail/databases/ is where blink stores its "tracker databases" for local storage, not sure why this bug hits us only now but I don’t think that’s a regression introduced by oxide 1.1.0.

It looks like we need to add RW permissions for @{HOME}/.local/share/@{APP_PKGNAME}/ to the oxide_helper profile in the webview policygroup.

Olivier Tilloy (osomon) on 2014-07-09
affects: webbrowser-app → webapps-core
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: New → Confirmed
Changed in webapps-demo (Ubuntu):
status: New → Confirmed
Changed in apparmor-easyprof-ubuntu (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
Olivier Tilloy (osomon) wrote :

I’m seeing the same apparmor denial in the syslog in image #119 (i.e. with oxide 1.0.2, so it doesn’t seem to be an oxide 1.1 regression), although the app doesn’t crash, but the view doesn’t display anything either.

Jamie Strandboge (jdstrand) wrote :

I already have a patch prepared. I will upload it toady.

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor-easyprof-ubuntu - 1.2.9

---------------
apparmor-easyprof-ubuntu (1.2.9) utopic; urgency=medium

  * ubuntu/webview:
    - adjust to allow oxide_render access to WebCore databases (LP: #1339724)
    - adjust for updated path for QML web plugin (LP: #1339777)
  * ubuntu/1.2: add new push-notification-client policy group
  * ubuntu/ubuntu-{sdk,webapp}: adjust for updated path for QML web plugin
  * ubuntu/audio: allow read access for /usr/share/sounds and
    /custom/usr/share/sounds (LP: #1340326)
  * ubuntu/audio: allow write access to /android/micshm (LP: #1337582)
 -- Jamie Strandboge <email address hidden> Thu, 10 Jul 2014 12:28:30 -0500

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
Olivier Tilloy (osomon) wrote :

I can confirm this is fixed in image #125 (tested on N7).

Changed in webapps-core:
status: Confirmed → Invalid
Changed in webapps-demo (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers