Update Twitter icons

Bug #1068207 reported by Alexandre Abreu on 2012-10-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
WebApps: Applications Data
Undecided
Unassigned
unity-webapps-twitter (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned
webapps-applications (Ubuntu)
Medium
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Twitter icons need to be updated, a new set of icons have been provided.

Revision history for this message
Alexandre Abreu (abreu-alexandre) wrote :

Risks of regression: low, only the icons will be changed and the names are being kept,

Steps to verify:
  - install twitter WebApp,
  - make sure that the icon appears and matches the one expected,

Changed in unity-webapps-twitter (Ubuntu):
importance: Undecided → Medium
milestone: none → quantal-updates
Changed in webapps-applications:
status: New → Fix Released
Changed in unity-webapps-twitter (Ubuntu):
status: New → Confirmed
Revision history for this message
Clint Byrum (clint-fewbar) wrote : Please test proposed package

Hello Alexandre, or anyone else affected,

Accepted unity-webapps-twitter into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-webapps-twitter/2.4.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in unity-webapps-twitter (Ubuntu Quantal):
status: New → In Progress
importance: Undecided → Medium
Revision history for this message
Ken VanDine (ken-vandine) wrote :

Marked this as affects the webapps-applications package as well, the unity-webapps-common package includes the incorrect icon when in fact those icons shouldn't be included.

Changed in webapps-applications (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

The SRU that's been uploaded to the queue for this issue includes additional upstream changes to the following files which are not documented in the debian changelog or linked to bugs:

  src/FacebookMessenger/FacebookMessenger.user.js
  src/GMail/GMail.user.js
  src/GooglePlus/GooglePlus.user.js
  src/GooglePlusGames/GooglePlusGames.user.js
  src/grooveshark/grooveshark.user.js
  src/Twitter/Twitter.user.js
  src/YouTube/YouTube.user.js

Without information about why these changes are included, this upload does not meet the Ubuntu SRU policy. In particular, there is no information about how we should verify that these changes fix the issues they are intended to fix, and that they have not introduced any regressions.

I'm therefore rejecting this upload from the quantal-proposed queue. Please reupload after addressing this issue, either by including references to appropriate bugs in debian/changelog for each of the changes, or by omitting these changes from the upload.

Changed in webapps-applications (Ubuntu Quantal):
status: New → Incomplete
Revision history for this message
Ken VanDine (ken-vandine) wrote :

These changes are included in the upstream sources but not in the resulting binary package (unity-webapps-common). The individual webapps packages are generated from the same upstream project sources but are only included in the install if built with --enable-applications. The fixes in those files have been included in other package uploads for unity-webapps-youtube, unity-webapps-twitter, etc.

Changed in webapps-applications (Ubuntu Quantal):
status: Incomplete → New
Revision history for this message
Steve Langasek (vorlon) wrote :

ok, thanks for the clarification. I'll pull this back out of the reject queue then.

Changed in webapps-applications (Ubuntu Quantal):
status: New → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello Alexandre, or anyone else affected,

Accepted webapps-applications into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/webapps-applications/2.4.10-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Will Cooke (willcooke) wrote :

Changed tag to verification done. New icons are visible, no regressions.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webapps-applications - 2.4.10-0ubuntu2

---------------
webapps-applications (2.4.10-0ubuntu2) raring; urgency=low

  * Upload for raring
 -- Ken VanDine <email address hidden> Fri, 09 Nov 2012 14:59:57 -0500

Changed in webapps-applications (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webapps-applications - 2.4.10-0ubuntu1

---------------
webapps-applications (2.4.10-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Fixed: Language detection code will not work for all
      languages (LP: #1065422)
    - new translations
  * -debian/patches/lp_1064260.patch, upstream
  * -debian/patches/bzr_extract_strings.patch, upstream
  * -debian/patches/dont-add-launchers-on-edubuntu, upstream
  * debian/patches/lp_1068207.patch
    - Don't install all the webapps icons, they are in the individual
      packages (LP: #1068207)
 -- Ken VanDine <email address hidden> Wed, 24 Oct 2012 08:50:15 +0200

Changed in webapps-applications (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-webapps-twitter - 2.4.10

---------------
unity-webapps-twitter (2.4.10) quantal-proposed; urgency=low

  * Update Twitter icons (LP: #1068207)
  * Improved loading of userscript (LP: #1068312)
 -- Alexandre Abreu <email address hidden> Thu, 18 Oct 2012 10:01:19 -0400

Changed in unity-webapps-twitter (Ubuntu Quantal):
status: In Progress → Fix Released
Changed in unity-webapps-twitter (Ubuntu):
status: Confirmed → Fix Released
Adolfo Jayme (fitojb) on 2014-02-07
no longer affects: webapps-applications (Ubuntu Raring)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers