Accounts not added into UOA when login on facebook.com or gmail.com

Bug #1066917 reported by Xavier Claessens on 2012-10-15
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Online Accounts: Browser Extensions
Critical
Alberto Mardegan
Online Accounts: GNOME Control Center
High
Alberto Mardegan
Online Accounts: libsignon-glib
Unknown
Unknown
gnome-control-center-signon (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
libsignon-glib (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
webaccounts-browser-extension (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

SRU information appears in comment #3.

I've created a new test user on my system to be sure there are no old settings that could interfer.

Steps:
1) log into unity with a fresh user
2) open firefox and go to facebook.com
3) type login/password
4) click "yes" when asking for extra features
5) go to system settings->online accounts

Expected:
See a facebook account

Actually:
Accounts list is empty

Related branches

Xavier Claessens (zdra) wrote :
Alberto Mardegan (mardy) on 2012-10-17
Changed in online-accounts-browser-extension:
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → Critical
status: New → Confirmed
information type: Proprietary → Public
Changed in online-accounts-gnome-control-center:
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → High
status: New → In Progress
Alberto Mardegan (mardy) on 2012-10-17
Changed in online-accounts-browser-extension:
status: Confirmed → In Progress
Alberto Mardegan (mardy) on 2012-10-17
Changed in online-accounts-gnome-control-center:
status: In Progress → Fix Committed
Alberto Mardegan (mardy) on 2012-10-17
Changed in online-accounts-browser-extension:
status: In Progress → Fix Committed
Alberto Mardegan (mardy) on 2012-10-17
no longer affects: ubuntu
Changed in online-accounts-browser-extension:
status: Fix Committed → Fix Released
Changed in online-accounts-gnome-control-center:
status: Fix Committed → Fix Released
Alberto Mardegan (mardy) wrote :

Some words about the proposed fixes:

The releases of libsignon-glib and online-accounts-gnome-control-center address the bug that once the credentials are captured, the user needs to re-login to the website in the Online Accounts panel.
How to reproduce:
  1) make sure you have no twitter account in Online Accounts (if you have it, delete it);
  2) make sure that the dconf key "com.canonical.webcredentials.capture.dontask-accounts" does not mention twitter (if it does, reset the key);
  3) open twitter.com in Firefox (accept the webapps integration if you didn't accept it before)
  4) login into twitter, if you are logged out (a twitter icon should appear in the launcher -- if it doesn't, it means that webapps was not configured correctly in your machine)
  5) the Online Accounts panel should be open

If the bug is fixed, then you should be already logged in in the twitter page in Online Accounts; if the bugfix is not correct, then you will be asked for username and password again.

The release of the online-accounts-browser extension fixes a Firefox crash.
How to reproduce:
1) Continue from the 5 steps above.
2) Abort the account creation (click on "Cancel")
3) Clear the dconf key (same as step 2 above)
4) logout of twitter (do NOT close the browser)
5) login into twitter again

If the bug is fixed, FF should not crash.

The regression risk for both fixes is nearly zero; the patches are small and touch only those code paths which are involved in the credentials capture functionality.

David King (amigadave) on 2012-10-25
Changed in online-accounts-gnome-control-center:
milestone: none → 0.0.20
Changed in libsignon-glib (Ubuntu):
importance: Undecided → High
Changed in libsignon-glib (Ubuntu Quantal):
importance: Undecided → High
Changed in gnome-control-center-signon (Ubuntu):
importance: Undecided → High
Changed in gnome-control-center-signon (Ubuntu Quantal):
importance: Undecided → High
Changed in webaccounts-browser-extension (Ubuntu):
importance: Undecided → Medium
Changed in webaccounts-browser-extension (Ubuntu Quantal):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsignon-glib - 1.7-0ubuntu1

---------------
libsignon-glib (1.7-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Fixed handling of GValues of type G_TYPE_VARIANT (LP: #1066917)
  * debian/control
    - make gir1.2-signon-1.0 depend on libsignon-glib1
 -- Ken VanDine <email address hidden> Thu, 08 Nov 2012 12:42:04 -0500

Changed in libsignon-glib (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webaccounts-browser-extension - 0.4.5-0ubuntu1

---------------
webaccounts-browser-extension (0.4.5-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Do not load the libwebaccounts library more than once (LP: #1066917)
 -- Ken VanDine <email address hidden> Thu, 08 Nov 2012 12:44:23 -0500

Changed in webaccounts-browser-extension (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center-signon - 0.0.20-0ubuntu1

---------------
gnome-control-center-signon (0.0.20-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Fix the passing of cookies to signon-ui (LP: #1066917)
  * debian/control
    - removed unneeded build depends for libdbus-glib-1-dev
    - build depend on libsignon-glib-dev >= 1.7 to get fix for (LP: #1066917)
 -- Ken VanDine <email address hidden> Thu, 08 Nov 2012 12:43:17 -0500

Changed in gnome-control-center-signon (Ubuntu):
status: New → Fix Released
description: updated

Hello Xavier, or anyone else affected,

Accepted libsignon-glib into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libsignon-glib/1.7-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libsignon-glib (Ubuntu Quantal):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Xavier, or anyone else affected,

Accepted webaccounts-browser-extension into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/webaccounts-browser-extension/0.4.5-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in webaccounts-browser-extension (Ubuntu Quantal):
status: New → Fix Committed
Chris Halse Rogers (raof) wrote :

The gnome-control-center-signin upload in quantal-proposed appears to have some unrelated changes in cc-credentials-accounts-model.vala. If they're not, in fact, unrelated, give me a ping.

Alberto Mardegan (mardy) on 2012-12-14
Changed in gnome-control-center-signon:
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center-signon (Ubuntu Quantal):
status: New → Confirmed
Michael Terry (mterry) wrote :

Chris, Ken: I've re-uploaded Ken's patch to quantal-proposed (0.0.18-0ubuntu1.1). Please re-process. Thanks, and sorry for the trouble!

Brian Murray (brian-murray) wrote :

Hello Xavier, or anyone else affected,

Accepted gnome-control-center-signon into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center-signon/0.0.18-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center-signon (Ubuntu Quantal):
status: Confirmed → Fix Committed
Víctor R. Ruiz (vrruiz) wrote :

1. Fresh Quantal install, up to date:
- Facebook account is created.
- But Firefox crashes.

2. Fresh Quantal install, with quantal-proposed and gnome-control-center-signon 0.0.18-0ubuntu1.1
- Twitter account is created.
- Firefox still crashes.

Alberto Mardegan (mardy) wrote :

Victor, which versions of webaccounts-browser-extension and libsignon-glib are you using?

xul-ext-webaccounts:
  *** 0.4.4-0ubuntu1 0
         500 http://es.archive.ubuntu.com/ubuntu/ quantal/universe i386
Packages

libsignon-glib1:
   Installed: 1.7-0ubuntu0.1
  *** 1.7-0ubuntu0.1 0
         500 http://es.archive.ubuntu.com/ubuntu/ quantal-proposed/main
i386 Packages

Alberto Mardegan (mardy) wrote :

Victor, see comment #5: you also need xul-ext-webaccounts 0.4.5.

David King (amigadave) on 2013-02-21
Changed in gnome-control-center-signon:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

This SRU has remained unverified after 343 days in the -proposed queue. I've removed it now from quantal-proposed and am marking this bug 'wontfix'.

Changed in gnome-control-center-signon (Ubuntu Quantal):
status: Fix Committed → Won't Fix
Changed in libsignon-glib (Ubuntu Quantal):
status: Fix Committed → Won't Fix
Changed in webaccounts-browser-extension (Ubuntu Quantal):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.