can't mark comments as spam on our Wordpress blog

Bug #731573 reported by Nelson Pavlosky on 2011-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Web Team projects
High
Unassigned

Bug Description

Steps to replicate:
1) Log into Wordpress
2) Try to hit the "spam" link on one of the "Pending" comments.
3) See the comment appear to be marked as spam (or, unpredictably, some other comment that you didn't intend to mark as spam gets marked as spam)
4) Reload the page
5) See how all of the comments are still pending and no comments have been successfully marked as spam.

Asheesh Laroia (paulproteus) wrote :

Next step:

* Install FireBug
* Load the FC.o blog
* Tools->FireBug
* Click on the "net" tab
* Do the same action you described above
* Look at the HTTP traffic caused by the "Spam" click
* Paste the server response into a comment on this bug

If you do that, we can see what's up?

P.S. Probably this happens related to the table move that Parker did.

P.P.S. Failed AJAX form submissions being visually marked as "success" are an indication of low-quality code. Yay WordPress.

Asheesh Laroia (paulproteus) wrote :

Related question: Does it work on other blogs that are part of our WP MU hosting?

Changed in web:
importance: Undecided → Medium
importance: Medium → High
Parker Phinney (gameguy43) wrote :

I also can't successfully create a new user. I created him, but he's unable to log in (he's either redirected to the non-admin homepage or told that he has insufficient permissions). This is probably because the dropdown chooser for his user permissions contained no options.

i suspect that these problems are all because of my database surgery. I guess the next action is to undo what I did and then re-evaluate?

Alec Story (astory) wrote :

Nelson: please try with javascript disabled and report back.

Asheesh is investigating server-side

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers