Dynamically generated map of our chapters from our database

Bug #40187 reported by Nelson Pavlosky
8
Affects Status Importance Assigned to Milestone
Web Team projects
Wishlist
Abhay Kumar

Bug Description

Perhaps this article would be of use in making a Google Map of our chapters?

http://www.earthcode.com/ajax/2006/04/rails_geocoding_and_google_map.html

At any rate, I'd like to have a map of our chapters that is automatically created from the database, from the school's street address or latitude and longitude, whichever is easiest to automate. It should also feature a link to the chapter's website if it exists, etc.

description: updated
description: updated
Sid (sid-srivastava)
Changed in web:
assignee: nobody → sid-srivastava
Revision history for this message
Asheesh Laroia (paulproteus) wrote :

See /home/freecult/public_html/chapters/noteasy.php and /home/freecult/public_html/chapters/phoogle.php and /home/freecult/public_html/chapters/gmaptest.html for the work I began and halted.

Revision history for this message
Sid (sid-srivastava) wrote :

Check out http://freeculture.org/chapters/noteasy.php to see a map of our chapters. There are two basic controls: zooming in on a state, and going back to the default, zoomed-out view. Each marker has a link to the school and the school's FreeCulture.org chapter.

Please comment. For example, right now, the map is very US-centric.

Revision history for this message
Asheesh Laroia (paulproteus) wrote : Re: [Bug 40187] Re: Dynamically generated map of our chapters from our database

On Tue, 2 May 2006, Siddharth Srivastava wrote:

> Check out http://freeculture.org/chapters/noteasy.php to see a map of
> our chapters. There are two basic controls: zooming in on a state, and
> going back to the default, zoomed-out view. Each marker has a link to
> the school and the school's FreeCulture.org chapter.

This totally rocks!

> Please comment. For example, right now, the map is very US-centric.

Yeah, I had that problem, too. I'm sure you can get over that hump,
though. The big question isn't how to get the data; that's easy enough.
But how do you display it well? When you click [-] three times, the map
goes to a view where you can see the whole world; I guess that would have
to do.

-- Asheesh.

--
This door is baroquen, please wiggle Handel.
(If I wiggle Handel, will it wiggle Bach?)
   -- Found on a door in the MSU music building

Revision history for this message
Nelson Pavlosky (nelson-freeculture) wrote :

This is an an excellent start! I'm actually going to recommend that you put it up on the Chapters page... the chapters page is kind of ugly anyway, it can deal with a map that is rough around the edges. I think the "wow" factor is worth it ^_^

My main problem with it? The text doesn't seem to stay inside of the bubbles, it keeps escaping. Bizarrely, the problem fixes itself when I change the size of the text in my browser, but when I first load the page the text is always outside of its bubble.

Changed in web:
status: Unconfirmed → In Progress
Revision history for this message
Nelson Pavlosky (nelson-freeculture) wrote : The text escaping the bubble

This is a screenshot of what happens when I click on a bubble after I first load the page. I am using Firefox 1.5.0.2 on Mac OS X Tiger. The problem goes away if I zoom the text in or out.

Revision history for this message
Asheesh Laroia (paulproteus) wrote :

Also, the page takes a long time to load. That appears to be due to lots of requests to the geocoding API. Maybe we can cache latitude and longitude in the database, Siddharth?

I did make a column for that in the chapters table. I think using that might be the easiest thing.

Revision history for this message
Asheesh Laroia (paulproteus) wrote :

Aranis was going to look into caching as per the Web Team meeting on May 3.

Changed in web:
assignee: sid-srivastava → aranis
Revision history for this message
Sid (sid-srivastava) wrote :

http://freeculture.org/chapters/noteasy.php is now sped-up by almost 50x (optimization +1, evil 0). However, I'm not going to incorporate into chapters.php just yet because:

* Not all chapters are showing up (I think I can fix this relatively easily)
* I need to modify the HTML for each marker bubble to see if I can fix the visual problem reported by Nelson

Revision history for this message
Sid (sid-srivastava) wrote :

Woops, zooming in on the state of Georgia zooms onto the country Georgia (as in, the one next to Azerbaijan). See if you spot more quirks like these.

Revision history for this message
Sid (sid-srivastava) wrote :
Changed in web:
status: In Progress → Fix Released
Revision history for this message
Nelson Pavlosky (nelson-freeculture) wrote : Re: [Bug 40187] Re: Dynamically generated map of our chapters from our database

Northeastern is incorrectly located in Connecticut b/c our contact put
that down as her mailing address. You want to use the school's street
address (Boston, MA) for the location, not the contact's mailing
address. Of course, this may necessitate filling in that field for some
of the chapters....

~Nelson~

Siddharth Srivastava wrote:

>Map is incorporated at http://freeculture.org/chapters/chapters.php. I
>wrote a blog post about it too: http://freeculture.org/blog/2006/05/11
>/quick-tour-of-our-new-chapters-map/.
>
>** Changed in: web (upstream)
> Status: In Progress => Fix Released
>
>
>

Revision history for this message
Nelson Pavlosky (nelson-freeculture) wrote :

As commented previously, Northeastern is incorrectly located in CT based on contact address, should be based on school address.

Also, there is an intermittent bug with the speech bubbles where they get covered up by blocks of the map, but it seems to have gone away for now, I'll post screenshots if I see it again.

Changed in web:
status: Fix Released → Fix Committed
Revision history for this message
Sid (sid-srivastava) wrote : Re: [Bug 40187] Re: Dynamically generated map of our chapters from our database

Northeastern is now (I believe) pointing to the right place.

On 5/12/06, Nelson Pavlosky <email address hidden> wrote:
> As commented previously, Northeastern is incorrectly located in CT based
> on contact address, should be based on school address.
>
> Also, there is an intermittent bug with the speech bubbles where they
> get covered up by blocks of the map, but it seems to have gone away for
> now, I'll post screenshots if I see it again.
>
> ** Changed in: web (upstream)
> Status: Fix Released => Fix Committed
>
> --
> Dynamically generated map of our chapters from our database
> https://launchpad.net/bugs/40187
>

Revision history for this message
Nelson Pavlosky (nelson-freeculture) wrote :

I'm satisfied with this map. If nobody sees any other bugs, I think it's safe to declare it finished. I don't see any flaws or functions that really need adding.

Changed in web:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers