host web irc client

Bug #129950 reported by Parker Phinney on 2007-08-02
2
Affects Status Importance Assigned to Milestone
Web Team projects
Critical
Asheesh Laroia

Bug Description

looks like you already tried to do this: bug #115367
http://www.ircatwork.com/ is down, their server got overloaded and they cant afford to expand. we should host our own. they used cgiirc: http://cgiirc.org/ . I dunno whether or not we have cgi installed on the server, but we really ought to have our own web-based irc client that we can maintain ourselves, cgiirc may or may not be the best way to go.

Parker Phinney (gameguy43) wrote :

just to show the actual importance, i'm initaly right now and for the next month with no way of getting in the irc channel. people DO actually use the web-based one.

I'll add this to the agenda for the upcoming strategy meeting and discuss whether we want to do this. (If so, I'll change to status: Confirmed).

The best way to help is to do some research on what it takes to install and operate CGI::IRC or similar packages.

Changed in web:
importance: Undecided → Wishlist
status: New → Incomplete

On Thu, 2 Aug 2007, Gavin Baker wrote:

> I'll add this to the agenda for the upcoming strategy meeting and
> discuss whether we want to do this. (If so, I'll change to status:
> Confirmed).
>
> The best way to help is to do some research on what it takes to install
> and operate CGI::IRC or similar packages.

We had it installed. Unfortunately, we would get people timing out to and
from us, so I figured we'd be better off switching.

I think freeculture.org/cgi-bin/cgiirc.cgi or some-such probably still
works.

-- Asheesh.

Asheesh Laroia (paulproteus) wrote :

On Thu, 2 Aug 2007, Gavin Baker wrote:

> I'll add this to the agenda for the upcoming strategy meeting and
> discuss whether we want to do this. (If so, I'll change to status:
> Confirmed).

Not letting people come to our strategy meeting because they don't have
IRC is not okay. Therefore, this is to be done before the meeting.

The address Asheesh linked as a CGI::IRC install at FC.o is broken.

I wouldn't call it "not letting people come" but it's a good point that people do use this, and we have meetings upcoming, so we want to get this straightened out.

In fact, we'll have another bylaws meeting on Sunday, so we should have it up by then if possible.

So we've decided to do this. Can we have it done by Sunday for the bylaws meeting?

Changed in web:
importance: Wishlist → Critical
status: Incomplete → Confirmed

Asheesh, is there anything we can do re: timeouts?

Asheesh Laroia (paulproteus) wrote :

We'll use the acm.jhu.edu one, which I happen to also (jointly) maintain.

Asheesh Laroia (paulproteus) wrote :

We're using the acm.jhu.edu one now. Ya-hoo, no need to figure out why ours wasn't working.

Changed in web:
assignee: nobody → ubuntu-asheesh
status: Confirmed → Fix Released

What's the URI for this?
Also, where is it linked from the FC.o site?

Asheesh Laroia (paulproteus) wrote :

On Wed, 15 Aug 2007, Gavin Baker wrote:

> What's the URI for this?
> Also, where is it linked from the FC.o site?

freeculture.org/contact/ has a link to it (now, it didn't last night), and
also freeculture.org/blog/ has the "Chat with us!" form on the
bottom-right (working as of last night).

I leave any desired copy editing to someone else; the contact page is a
little weirdly organized but not catastrophically so.

-- Asheesh.

--
<SirDibos> does Johnie Ingram hang out here on IRC?

Cool.

Do we want to pick a URI that we can use to point to this and future instances of CGI::IRC? e.g. freeculture.org/irc ?

Parker Phinney (gameguy43) wrote :

issue1) it's down right now, might have to do with the fact that the internet in this library sucks, but i just can;t access it.

issue2) when you use the link at /contact, the form that comes up asks for a username and says that its going to connect you to #freeculture, but it doesnt, it connects you to that other channel unless you go to advanced and choose free culture, or use /join once inside. haven't tried with the blog sidebar thing. this ought to be fixed since the target users for the web app are those who dont use irc often and aren't going to realize that they're not in the right channel.

hope that made sense. shouldn't be hard for someone to replicate this.

Asheesh Laroia (paulproteus) wrote :

I fixed these issues; thanks for the note. See http://freeculture.org/pipermail/webteam/2007-September/000102.html .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers