We don't do backups

Bug #125661 reported by Asheesh Laroia on 2007-07-12
2
Affects Status Importance Assigned to Milestone
Web Team projects
Medium
Asheesh Laroia

Bug Description

We don't back up our files, nor our databases.

We should use a cron job that mysqldumps our DBs, gzips them, and stores them as files somewhere nightly.

We should then back up all those files, which together are enough to recreate the fc.o web site and 'net services in case of emergency.

Asheesh Laroia (paulproteus) wrote :

This, like, matters. I'll start us doing backup somewhere tomorrow morning, since it matters so much.

Changed in web:
assignee: nobody → ubuntu-asheesh
importance: Undecided → Critical
status: New → Confirmed
Asheesh Laroia (paulproteus) wrote :

Files are being backed up now. You need sudo to configure it.

Databases are not; I'll work on that. Something like http://openconcept.ca/mysql_permissions_for_backup would be useful.

The problem is that we have many fco databases, each with different usernames and passwords. I think the best solution is just to list these username/password pairs somewhere, and just use that list in doing the nightly backup job.

Asheesh Laroia (paulproteus) wrote :

A full file backup succeeded to my work machine, which isn't a great place for backups but will do for now. Tomorrow I can verify that incremental backups are also working.

I'm working on database backup now, which will conclude the backup set.

Asheesh Laroia (paulproteus) wrote :

All databases listed in ~/passwords/mysql_passwords will get backed up nightly.

Tomorrow I'll add a regex feature to the db backup program to check for databases it doesn't make backups of, and by then I'll be able to verify nightly backups are working and close this for good.

Changed in web:
importance: Critical → Medium
status: Confirmed → In Progress
Asheesh Laroia (paulproteus) wrote :

That magic regex feature I wanted is now implemented. I'll get emailed every night if a database isn't being backed up, and right now, I wouldn't get emailed at all.

I just checked, and on the creation of a new database it would work correctly.

I can now sleep easier at night.

Changed in web:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers