Add CC licensing

Bug #125195 reported by Gavin Baker on 2007-07-11
0
Affects Status Importance Assigned to Milestone
Web Team projects
High
Asheesh Laroia

Bug Description

Add link to CC license in footer ("Some rights reserved" current doesn't link anywhere)

Add metadata

IIRC the appropriate license is by 3.0

Changed in web:
importance: Undecided → High
status: New → Confirmed

We have the wpLicense plugin installed, version 0.7.6.1, but I haven't figured out how to include it properly in our theme. In our WP admin panel, if you go to Options -> CC Content License, you can change the license and "include license badge in default footer". "If you select "Include License Badge", the default Creative Commons badge, link and RDF will be included in the standard footer."

I tried turning that option on, but the license button appears above our footer, in the whitespace between the content and the grey footer. That's not where it's supposed to go! It looks like we're going to have to include a special function in our footer to get the license button to appear where we want it... see http://wiki.creativecommons.org/WpLicense_Function_Reference

Changed in web:
status: Confirmed → In Progress
Asheesh Laroia (paulproteus) wrote :

Fixed:

<a href="<?php echo licenseUri(); ?>">Some rights reserved</a>.

Changed in web:
assignee: nobody → ubuntu-asheesh
status: In Progress → Fix Released

Re-opening, metadata is still missing and/or not working

Changed in web:
status: Fix Released → Triaged

Fixed. All it took was rel="license". Asheesh, you WORK for Creative Commons. Why did this take so long?!

Changed in web:
status: Triaged → Fix Released

For the record, the CC license is now hardcoded into the theme (in the footer), and the wpLicense plugin has been deactivated. It didn't return results in a useful way, and it's easier to just do it ourselves.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers