Forecast crash: ValueError: could not convert string to float: Unknown

Bug #886028 reported by Tomasz Maciejewski on 2011-11-04
126
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Weather Indicator
High
Vadim Rutkovsky
indicator-weather (Ubuntu)
Medium
Vadim Rutkovsky
Oneiric
Undecided
Unassigned

Bug Description

Neither for Google or Yahoo! Here the log:

[MainThread] 2011-11-04 10:25:44,412 - DEBUG - Indicator: updateWeather: updating weather for ['12577946', 'Wroc\xc5\x82aw']
[Cache] 2011-11-04 10:25:44,414 - DEBUG - Settings: getting cached weather for 12577946
[Fetcher] 2011-11-04 10:25:44,414 - DEBUG - Indicator: getWeather for location 'Wrocław, Województwo dolnośląskie, Polska'
[Fetcher] 2011-11-04 10:25:44,415 - DEBUG - Indicator: getWeather: updating weather report
[Fetcher] 2011-11-04 10:25:44,415 - DEBUG - Location: non default weather source 'Google' chosen for 'Wrocław'
[Cache] 2011-11-04 10:25:44,415 - DEBUG - Indicator: loading weather from cache for ['12577946', 'Wroc\xc5\x82aw']
[Cache] 2011-11-04 10:25:44,416 - DEBUG - Indicator: menu_normal: filling in a menu for found places
[Cache] 2011-11-04 10:25:44,416 - DEBUG - Indicator: menu_normal: adding first location menu item 'Wrocław'
[Cache] 2011-11-04 10:25:44,416 - DEBUG - Indicator: menu_normal: adding location menu item 'Kalisz'
[Cache] 2011-11-04 10:25:44,435 - DEBUG - Indicator: update_label: setting label to ' '
[Cache] 2011-11-04 10:25:44,439 - DEBUG - Indicator: setting refresh label to 'Refreshing, please wait'
[Cache] 2011-11-04 10:25:44,440 - DEBUG - Indicator: update_label: setting label to '18 ˚C'
[Fetcher] 2011-11-04 10:25:44,620 - ERROR - Weather: could not get weather icon from report
[Fetcher] 2011-11-04 10:25:44,621 - ERROR - Weather: got data '{}'
[Fetcher] 2011-11-04 10:25:44,621 - ERROR - ExtendedForecast: unknown Google weather condition ''
[Fetcher] 2011-11-04 10:25:44,621 - DEBUG - Weather: current condition: '', '(False, False, False, 'Nieznane warunki pogodowe')'
[Fetcher] 2011-11-04 10:25:45,512 - DEBUG - Weather: got localtime 2011-11-04 10:35:49, dst 0, sunrise '06:50:29', sunset '16:19:00', night = False
[Fetcher] 2011-11-04 10:25:45,512 - DEBUG - Indicator: updateWeather: waiting for 'Cacher' thread to terminate
[Fetcher] 2011-11-04 10:25:45,512 - DEBUG - Indicator: updateWeather: got condition 'Nieznane warunki pogodowe', icon 'weather-few-clouds'
[Fetcher] 2011-11-04 10:25:45,513 - DEBUG - Weather: day, show 'False' icon
[Fetcher] 2011-11-04 10:25:45,514 - ERROR - could not convert string to float: Unknown
[Fetcher] 2011-11-04 10:25:45,514 - DEBUG - Traceback (most recent call last):
  File "/usr/bin/indicator-weather", line 1374, in get_new_weather_data
    log.debug("Indicator: fill in menu with params: city='%s', temp='%s', humid='%s', wind='%s', sunrise='%s', sunset='%s', puretemp=%s" % (self.places[self.placechosen][1], weather.get_temperature_label(), weather.get_humidity_label(), weather.get_wind_label(), weather.get_sunrise_label(), weather.get_sunset_label(), weather.get_temperature()))
  File "/usr/bin/indicator-weather", line 858, in get_wind_label
    _value = float(wind_speed) * 1.609344
ValueError: could not convert string to float: Unknown

[Fetcher] 2011-11-04 10:25:45,514 - DEBUG - Indicator: scheduling update in 15 mins
[MainThread] 2011-11-04 10:25:48,610 - DEBUG - Indicator: open Preferences
[MainThread] 2011-11-04 10:25:48,611 - DEBUG - Preferences: creating
[MainThread] 2011-11-04 10:25:48,617 - DEBUG - Preferences: finishing initialization
[MainThread] 2011-11-04 10:25:48,617 - DEBUG - Preferences: got settings: unit=S, notif=O, wind=kph, rate=15, source=Y
[MainThread] 2011-11-04 10:25:48,618 - DEBUG - Preferences: Loading places
[MainThread] 2011-11-04 10:25:48,618 - DEBUG - Preferences: Places: got (Wrocław, 12577946)
[MainThread] 2011-11-04 10:25:48,618 - DEBUG - Preferences: Places: got (Kalisz, 498173)
[MainThread] 2011-11-04 10:25:56,853 - DEBUG - Preferences: Cancelling
[MainThread] 2011-11-04 10:26:28,102 - DEBUG - Indicator: setting refresh label to 'Odśwież (2 min. temu)'
[MainThread] 2011-11-04 10:26:28,103 - DEBUG - Indicator: scheduling refresh label update in 1 min

Changed in weather-indicator:
status: New → Confirmed
summary: - Can't get weather for Wrocław (Dolnośląskie, Poland)
+ Forecast crash: ValueError: could not convert string to float: Unknown
Changed in weather-indicator:
assignee: nobody → Vadim Rutkovsky (roignac)
importance: Undecided → High
milestone: none → cloudy-9
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
Vadim Rutkovsky (roignac) wrote :

Commited a patch in rev 296, many thanks to Tomasz Maciejewski!

Changed in weather-indicator:
status: Triaged → Fix Committed
Changed in indicator-weather (Ubuntu):
assignee: nobody → Vadim Rutkovsky (roignac)
Changed in weather-indicator:
status: Fix Committed → Fix Released
Changed in weather-indicator:
status: Fix Released → Fix Committed
Changed in weather-indicator:
status: Fix Committed → Fix Released
Changed in indicator-weather (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.11.28-0ubuntu1

---------------
indicator-weather (11.11.28-0ubuntu1) precise; urgency=low

  * New upstream release.
   - Preferences buttons OK and Cancel and Forecast's Close
     are not focusable (LP: #853774)
   - Don't crash if Google doesn't return icons (LP: #809187)
   - Display degrees in wind info item if Yahoo is selected (LP: #838369)
   - Fixed Assistant behavior for Forward/Back movements (LP: #804659)
   - Fixed a crash when Unknown wind condition was returned, thanks
     Tomasz Maciejewski! (LP: #886028)
   - Don't write too much debug info in the log (LP: #917253)
  * Drop debian/patches/autostart.patch, applied upstream.
  * Drop debian/README.source, no longer needed.
 -- Andrew Starr-Bochicchio <email address hidden> Fri, 20 Jan 2012 15:25:46 -0500

Changed in indicator-weather (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-weather (Ubuntu Oneiric):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in indicator-weather (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers