sunrise and sunset info incorrect

Bug #770652 reported by Karen T. Kohl on 2011-04-26
252
This bug affects 47 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Status tracked in 2.0
2.0
High
Unassigned
3.0
High
Unassigned
indicator-weather (Ubuntu)
Undecided
Unassigned

Bug Description

11.04.24

I've added 2 cities within the same time zone to check this.
Both say the same sunrise and same sunset. Both are incorrect for both cities.
Same info for Google or Yahoo source choice.

Other details seem correct.

Related branches

Vadim Rutkovsky (roignac) wrote :

Please, specify Weather Indicator version and attach logs from ~/.cache/indicator-weather.log

Changed in weather-indicator:
status: New → Incomplete
Karen T. Kohl (ktkohl96) wrote :

11.04.24

log attached noq

description: updated
Cas (calumlind) wrote :

I have the same issue and have attached my log too.

Vadim Rutkovsky (roignac) wrote :

It seems, that we have to switch from earthtools.org to a more reliable service

Changed in weather-indicator:
importance: Undecided → High
milestone: none → foggy
status: Incomplete → Confirmed
Aritchie (aritchie) wrote :

It is rather interesting. I went to two different websites - one of them being Earthtools and the two did report different sunrise\sunset times so it makes it a little bit of a challenge. The two sites were off by a minute or two.

robin0800 (robin-linux-hotmail) wrote :

My sunset time was off by two hours

Panagiotis Skintzos (ph7) wrote :

The problem is that we fed earthtools.org api with wrong coordinates (not the original ones from geonames, but transformed ones for google).
I made a fix for cloudy.
It also fixes two other problems:
- the daylight savings status was not taken correctly into account
- the day/night calculation was done with system local time not with the location's local time.

Important: For this to work, the location has to be deleted and added again (because the wrong coordinates are saved in the location details)

For foggy I'll update the branch later.
I'll make it so that we fetch the sunrise/sunset only once per day per location.

The real problem with earthtools is the limited coverage. If I remember right Gnome time applet had builtin sunrise/sunset calculation. I'll look into that.

Richard Reynolds (rhreynolds) wrote :

My sunset time is off by two hours as well. Sunrise appears to be only a few minutes off.

James (pug-ironfoot) wrote :

11.05.01 - tired deleting and re-adding the location, still out by 2 hours.

Panagiotis Skintzos (ph7) wrote :

Hi James & Richard, which is your location? It is possible that earthtools does not provide correct data for it.

James, could you specify the location?

for me the fix works just fine, times ar correct in my location now.
many thanks!

James (pug-ironfoot) wrote :

ingore its now fixed! took reboot. :)

Karen T. Kohl (ktkohl96) wrote :

Upgraded to 11.05.01, and that is better, but the times shown are now an hour early. Maybe DST was not selected for Earthtools?

Panagiotis Skintzos (ph7) wrote :

The problem is in earthtools, it does not specify if dst should be used, it gives "<dst>Unknown</dst>"
http://www.earthtools.org/timezone-1.1/30.3157527/-89.247543

We will switch to geonames.org for time information in next version; I'll make a patch for the current version as well.

Shimi Chen (shimi-chen) on 2011-06-08
affects: ubuntu → indicator-weather (Ubuntu)
Changed in indicator-weather (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.05.31-0ubuntu1

---------------
indicator-weather (11.05.31-0ubuntu1) oneiric; urgency=low

  * New upstream release.
   - Ported settings to dconf, which will solve a number of
     desktopcouch-related bugs
   - Fix for LP: #747733 "indicator-weather crashed with
     TypeError in next_page(): unknown type (null)"
   - Fix for LP: #756704 "Numbers (temperature etc.) do
     not use local number format"
   - Fix for LP: #770652 "sunrise and sunset info incorrect"
   - Fix for LP: #765464 "do not see indicator-weather on the panel"
   - Fix for LP: #769842 "Weather Indicator should clear up corrupted DB"
   - Fix for LP: #778941 "Weather Indicator can't be disabled"
   - Fix for LP: #796314 "ROUND_CEiLiNG error in Turkish locale"
   - Fix for LP: #780973 "indicator-weather crashed with Unauthorized in
     request(): ('unauthorized', 'Authentication required.')"
  * debian/control:
   - Adjust dependencies for desktop-couch to dconf transition.
   - Bump Standards-Version to 3.9.2.
   - Explictily depend on libgtk2.0-bin to ensure we have
     /usr/bin/gtk-update-icon-cache (LP: #808387).
  * Convert from python-support to dh_python2.
  * debian/rules:
   - Drop get-orig-source target, not needed.
   - Fix debian/postinst to check for symbolic links as well.
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 12 Jul 2011 01:44:53 -0400

Changed in indicator-weather (Ubuntu):
status: Fix Committed → Fix Released
Costis (ccostis) wrote :

Still sunrise & sunset times are -1h than local time (GMT+2).
(ver. 11.05.31)

Aibara Iduas (aibaraiduas) wrote :

As Costis above mentioned, this is still broken. I'm also using version 11.05.31 (in Oneiric), and the sunrise/sunset times for both Detroit and Toronto are listed as one hour earlier than they actually are.

My sunrise time is fine, but sunset is 1 hour early. This was using the yahoo source.

Leonid Evdokimov (darkk) wrote :

I have 11.05.31-0ubuntu2.1 and I'm at St.Petersburg (Russian Federation)
Applet shows sunrise / sunset at 10:05 / 15:53
http://pogoda.yandex.ru/saint-petersburg shows sunrise / sunset at 11:01 / 16:57 - and it represents reality much better then applet does :)

David Clayton (dcstar) wrote :

I can confirm that this problem still occurs for location Melbourne Australia in version 11.05.31 'Cloudy 8' on Ubuntu 11.10. Sunrise/Sunset times do not take into account current Daylight Saving time so they are offset by one hour.

Gnome 2 "Weather Report" applet running on same system reports correct times.

Sparhawk (sparhawkthesecond) wrote :

Also confirming that this I'm seeing the same problem for Melbourne, Australia, where Daylight Savings is not taken into account.

MarkieB (ubunt-u-markbenjamin) wrote :

Bug is present in 11.11.28 for Miami, FL, USA showing 18:50 sunset when the sunset is in fact 19:50 tonight

MarkieB (ubunt-u-markbenjamin) wrote :

Bizarre in fact as the gnome-shell weather in Fedora, fetching data from yahoo weather, has the correct sunset time.

MarkieB (ubunt-u-markbenjamin) wrote :

as adding astronomy is a relatively recent addition to gnome-shell weather, I cite the URL for comparison

http://query.yahooapis.com/v1/public/yql?format=json&q=select location,wind,atmosphere,units,item.condition,item.forecast,astronomy from weather.forecast where location="<appropriate woeid>" and u="<weather units>"

that's providing the correct sunset time, adjusted for DST;

while selecting 'google weather' in indicator-weather gives no sunset time, selecting 'yahoo weather' in indicator-weather leads to the bug; it must be retrieving from a different url than gnome-shell weather?

Jochen Cammin (joca) wrote :

I'm using ubuntu 12.04 LTS and Weather Indicator 11.11.28 'Cloudy 9'.
The sunrise/sunset time is still off by one hour for me.
I'm on the US east cost (Baltimore, MD).

NoOp (glgxg) wrote :

12.04:

$ apt-cache policy indicator-weather
indicator-weather:
  Installed: 11.11.28-0ubuntu1
  Candidate: 11.11.28-0ubuntu1
  Version table:
 *** 11.11.28-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
        100 /var/lib/dpkg/status

Sunrise/Sunset is 1 hour & few minutes off.
DEBUG - Indicator: fill in menu with params: city='San Francisco', temp='Temperature: 63 ˚F', humid='Humidity: 60%', wind='Wind: N , 5.2 knots', sunrise='Sunrise: 04:53', sunset='Sunset: 19:18', puretemp=63 ˚F

Should be:
Sunrise 05:55
Sunset 20:17

Same settings on 11.04 - the times are correct:
$ apt-cache policy indicator-weather
indicator-weather:
  Installed: 11.04.10+repack-0ubuntu2
  Candidate: 11.04.10+repack-0ubuntu2
  Version table:
 *** 11.04.10+repack-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

DEBUG - Indicator: fill in menu with params: city='San Francisco', temp='Temperature: 63 ˚F', humid='Humidity: 60%', wind='Wind: N , 5.2 knots', sunrise='Sunrise: 05:55:00 AM', sunset='Sunset: 08:17:00 PM', puretemp=63 ˚F

Ross Ashley (brashley46) wrote :

I'm in Toronto, ON. Updated using the PPA to version 12.07.30, now it updates just fine, but the sunrise and sunset times are "unknown". Won't display temp beside the symbol either.

Ross Ashley (brashley46) wrote :

Edit that: Switched to Google for the weather, and the sunrise and sunset times now display ... at 04:50:31 AM and 07:49:51 PM respectively. Real times are 06:13 AM and 8:33 PM, per http://www.timeanddate.com/worldclock/astronomy.html?n=250

Ross, the "unknown" lines are new, from a patch to deal with the data source failing. That was bug 964365. The indicator was not updating, when it couldn't get that info from earthtools.org. The improvement is to proceed without it, and update everything else.

As I understand it. :)

todaioan (alan-ar06) on 2012-08-07
Changed in indicator-weather (Ubuntu):
assignee: nobody → toda (alan-ar06)
NoOp (glgxg) wrote :

Please reopen for Ubuntu.

$ apt-cache policy indicator-weather
indicator-weather:
  Installed: 11.11.28-0ubuntu1.2
  Candidate: 11.11.28-0ubuntu1.2
  Version table:
 *** 11.11.28-0ubuntu1.2 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     11.11.28-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages

No change per my comment #27.

I undid toda's assignment of the bug to his-or-her-self. toda has been making changes in Launchpad that they may not understand, here and on other bugs. Thanks.

Changed in indicator-weather (Ubuntu):
assignee: toda (alan-ar06) → nobody
Sergey Romanovsky (romanovsky) wrote :

The problem is still here.
Version: 12.07.30-0ubuntu1.1
Location: Sunnyvale, CA, USA
Problem: Sunset time is about -1h

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions