still not updating weather data

Bug #760658 reported by Felix Lawrence on 2011-04-14
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Weather Indicator
High
Panagiotis Skintzos

Bug Description

It seems that Weather Indicator does not update weather forecast after resume from suspend/hibernate.
I'm using 11.04.10 version.
After resume, indicator shows "Refreshing, please wait"... but after a while it shows "Update (x min. ago)", where x >= update interval.

Felix Lawrence (felix-lawrence) wrote :
Changed in weather-indicator:
status: New → Confirmed
Felix Lawrence (felix-lawrence) wrote :

Jacopo: did you get any messages that indicator-weather had crashed?

this could be due to bug #760765.

Though the call to Weather.__init__ in update_weather must not be executing completely either, since the debug message "Weather: current condition..." is not in the log.

Another possibility is that there's a race condition between the cache thread and the fetching thread.

Panagiotis Skintzos (ph7) wrote :

Ok, I found the error.
Jacopo is your internet working immediately after the resume?

When the system resumes after sleeping for more time than the refresh rate interval, the program calls update_weather.
At that time there is no scheduling for updating the weather. The fetcher thread should reschedule the job, but it fails before doing so. An exception is raised (most probably a URL error) but it is not catched anywhere, so we don't see it at the log. You can see it if you start the program from the command line (just disable networking after the program starts).

I'll create a patch for this. Other bugs are are related to this

Changed in weather-indicator:
importance: Undecided → High
Jacopo Moronato (jmoronat) wrote :

@ Felix
No crash messages.

@ Panagiotis
Yes, notice that I'm using a netbook and a wifi connection.

Rocko (rockorequin) wrote :

I'm also using a wifi connection and I see the same behaviour after resume.

Btw, this looks like a duplicate of #742397, but that bug report thinks the bug is fixed.

Panagiotis Skintzos (ph7) wrote :

@Rocko: The problem is not in the resume; it just manifests itself after the resume, because the internet connection is not available right away. That bug was about the actual handling of suspend/resume and it is fixed.
I have start working on this one, hopefully during the weekend I'll have a fix.

Changed in weather-indicator:
status: Confirmed → Fix Committed
Changed in weather-indicator:
assignee: nobody → Panagiotis Skintzos (ph7)
milestone: none → 11.04.23
Changed in weather-indicator:
status: Fix Committed → Fix Released
Laryllan (laryllan) wrote :

Today I stumbled upon this bug too.

The description says:
Importance - high, fix released.

Why is the package not updated in 11.04?
I still get version 11.04.10+repack-0ubuntu2 which features this bug...

Vadim Rutkovsky (roignac) wrote :

@Larylan - the fix for this bug is in PPA version (ppa:weather-indciator/ppa), but Natty repositories have not been updated yet.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions