weather applet doesn't refresh information after resume

Bug #742397 reported by Pavol Klačanský
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Medium
Unassigned

Bug Description

Hi, if I suspend comp and then resume, indicator weather just show "Refreshing please wait", but it does not refresh it

Revision history for this message
Pavol Klačanský (pavolzetor-deactivatedaccount) wrote :
Revision history for this message
Eylem (eylemkoca) wrote :

I have refreshing problem too.
First off, it fails to refresh at start-up and keeps saying "Refreshing please wait". Then I manually refresh it. Then again, when I check on it some time later, it says "Refreshing please wait". I feel like auto refresh is completely broken. Please fix, it's not of use like this... Thanks!

Revision history for this message
Felix Lawrence (felix-lawrence) wrote :

@Eylem: are you using Google or Yahoo as the weather provider? (check the preferences)

Revision history for this message
Vadim Rutkovsky (roignac) wrote :

This seem to happen for several people. The problem is in gobject.timeout_add function

Changed in weather-indicator:
importance: Undecided → Medium
milestone: none → cloudy-3
status: New → Confirmed
Revision history for this message
Panagiotis Skintzos (ph7) wrote :

>The problem is in gobject.timeout_add function
I think that by detecting network availability we can also effectively detect resume/suspend and start/stop the timers. It'll also save cpu cycles and battery time on for-whatever-reason disconnected laptops.

Revision history for this message
Panagiotis Skintzos (ph7) wrote :

Here's a patch that adds support for power events.
It monitors the UPower dbus interface and handles the weather and refresh label updating schedules.

Revision history for this message
Vadim Rutkovsky (roignac) wrote :

Thanks, Panagiotis, works great!

Changed in weather-indicator:
status: Confirmed → Fix Committed
Changed in weather-indicator:
status: Fix Committed → Fix Released
Revision history for this message
molecule-eye (niburu1) wrote :

I'm using version 11.04.10 and observing refresh issues. Sometimes it works, but often it doesn't.

Revision history for this message
Rocko (rockorequin) wrote :

Which version is the fix in? I'm on 11.04.10+repack-0ubuntu2 and refresh doesn't work after resuming. It initially says "Refreshing please wait..." after resume, and then changes to "Refresh (485 minutes ago)" (obviously, the minutes part changes every minute).

Revision history for this message
tekstr1der (tekstr1der) wrote :

@Vadim Rutkovsky:

indicator-weather 11.04.10+repack-0ubuntu2 is the latest available in the repos for natty. This bug still exists and is unfixed in the current package version.

The status of this bug should be changed to "Fix Committed" if a fix has been committed upstream, but not yet released to natty-updates.

Revision history for this message
tekstr1der (tekstr1der) wrote :

Okay, I found Bug #760658 which seems to explain this bug's status and claims to be fixed in the next release, "Cloudy 5".

Revision history for this message
Vadim Rutkovsky (roignac) wrote :

Actually, the latest available version is 11.04.24 (upstream), and version, available in Natty repos, is 11.04.10+repack-0ubuntu2 (downstream).
So the bug is fixed in 11.04.24 version, grab the package from Weather Indicator PPA (ppa:weather-indicator-team/ppa) - the fix will be there. Later this package will be packaged in Natty, usually in a couple of days.

I just can't change milestone for this bug, as it is unavailable now.

Revision history for this message
Nerdfest (nerdfest) wrote :

I'm actually having this problem with it without ever using suspend/resume. I'm using Google as my weather source. I'll switch to Yahoo to see if it corrects the problem (version 11.04.10).

Revision history for this message
Bernhard (b.a.koenig) wrote :

The version in the Ubuntu repos is still 11.04.10. Could anybody package the new version? I think that would be nice since the weather indicator used to be in the default setup so many people are using it.

Revision history for this message
bwat47 (bwat47) wrote :

I'm still having this problem in 12.04.. makes this unusable.

Revision history for this message
bwat47 (bwat47) wrote :

nevermind, looks like it may have been a different issue, was still haveing problems even after reboot, it was refusing to refresh. ended up having to uninstall it, purge config files, and recursively reset gsettings and reinstall, seemed to fix it.

Revision history for this message
doru001 (headset001) wrote :

It can even crash if I click on Refresh too often.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers