indicator-weather crashed with KeyError in save_location_details(): 'yahoo id'

Bug #733760 reported by Pavol Klačanský on 2011-03-12
434
This bug affects 84 people
Affects Status Importance Assigned to Milestone
Weather Indicator
High
Panagiotis Skintzos

Bug Description

cannot add "Senica city"

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-weather 11.02.13+unstable+bzr204~natty1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
Architecture: amd64
CrashDB: indicator_weather
Date: Sat Mar 12 11:13:43 2011
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
ProcEnviron:
 LANGUAGE=sk_SK:sk_SK.UTF-8:sk:en_GB:en
 LANG=sk_SK.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/indicator-weather']
SourcePackage: indicator-weather
ThirdParty: True
Title: indicator-weather crashed with KeyError in save_location_details(): 'yahoo id'
UpgradeStatus: Upgraded to natty on 2011-02-19 (21 days ago)
UserGroups: adm cdrom dialout dip fax floppy fuse plugdev sambashare tape video

visibility: private → public
Changed in weather-indicator:
assignee: nobody → Vadim Rutkovsky (roignac)
importance: Undecided → High
milestone: none → cloudy
status: New → Confirmed
Vadim Rutkovsky (roignac) wrote :

Fixed in the bzr210 package in Unstable PPA

Changed in weather-indicator:
status: Confirmed → Fix Committed
Changed in weather-indicator:
status: Fix Committed → Fix Released

Has the fix reached the official packages? I just had this on a freshly updated system.

Vadim Rutkovsky (roignac) wrote :

Reopening per comment from Lucian.
Lucian, did this happen while adding Senica city or any other?

Changed in weather-indicator:
milestone: 11.03.20 → cloudy-3
Keith Drummond (victor9098) wrote :

This just happened to me when trying to add Dublin (Ireland).

Mohd Farimi Ab Rahman (farimi) wrote :

This also happened when I tried Gua Musang city

Szilu (szilard-varga) wrote :

This always happens when I would add a city, what is not in the list of service provider (Yahoo or Google).

Mohd Farimi Ab Rahman (farimi) wrote :

still happening to me

Keith Drummond (victor9098) wrote :

Programme still crashing

Carles Sentis (heepie202) wrote :

Same here...

Mohd Farimi Ab Rahman (farimi) wrote :

I wonder if this is going to be resolve before stable are release..?

Changed in weather-indicator:
status: Fix Released → Confirmed
Panagiotis Skintzos (ph7) wrote :

Reopening this, as it keeps happening for many cities that Yahoo does not support.
I think the only solution is that if a weather source (Yahoo in this case) is not available for a location, we support it by using the rest of weather sources (Google in this case).
So, even if Yahoo is chosen as default weather source, we provide weather from Google for these missing locations.
Perhaps we should notify the user somehow (maybe in the Assistant dialog)

Mohd Farimi Ab Rahman (farimi) wrote :

how to apply patch?

Keith Drummond (victor9098) wrote :

Still occurring for me on Ubuntu 11.04. I click the icon to set up weather, have changed the source between yahoo and google, went to add location (Dublin, Ireland), put the name as Dublin, then when I apply the settings it crashes.

Ubuntu 11.04 Beta
Version: 11.04.10+repack-0ubuntu2

PresuntoRJ (fabio-tleitao) wrote :

Just changed the weather source to Google but I still get an Yahoo_id error message when I try to add a few cities here in Brazil (like Campo Grande - Mato Grosso do Sul, which used to work in Ubuntu Classic with Gnome)

Changed in weather-indicator:
status: Confirmed → Fix Committed
Changed in weather-indicator:
assignee: Vadim Rutkovsky (roignac) → Panagiotis Skintzos (ph7)
milestone: 11.04.02 → 11.04.23
Vadim Rutkovsky (roignac) wrote :

Fixed in 11.04.24 version

Changed in weather-indicator:
milestone: 11.04.24 → none
status: Fix Committed → Fix Released
Édgar Alfonso (edgar-alfonso) wrote :

Today's update fixed the problem for me. Thanks a lot.

Tran Vinh Tan (vinhtantran) wrote :

Now I cannot add Ho Chi Minh city (Vietnam).

Panagiotis Skintzos (ph7) wrote :

This is fixed the unstable ppa. But we need to update the standard natty package, cause duplicates keep coming every day.

Greetings!

I would like to report that "Skopje" (Macedonia) could not be added as well.

What I've noticed is that when I search for the city, I get "Skopje, Karpoš, Macedonia" (where, "Skopje, Macedonia" should be better), while in Google: http://www.google.com/ig/api?weather=Skopje it says:
<city data="Skopje, Butel Municipality"/>
<postal_code data="Skopje"/>

Also, I've wanted to try and change the city data by myself, but I couldn't find indicator-weather in gconf-editor (and I couldn't find if it's written somewhere else). So, any solution to be done from my side, or I need to wait on a newer version?

Thank you guys for the hard and helpful work that you are doing!
Vasil

varun kumar (varunkumar-eie) wrote :

Hi,

I am unable to add my city also..It is kadapa,Andhra Pradesh,India.. When i click on the apply button,nothing happens.I have to do force quit the indicator-weather

Vasil:
you can try edit settings here (this file is in your home folder)

.local/share/desktop-couch/couchdb.html

because WI uses CouchDB to store settings and cache data instead of dconf (deprecated gconf)

Panagiotis Skintzos (ph7) wrote :

For the people still experiencing the problem:
This issue has been fixed in the version included in the PPA:
https://launchpad.net/~weather-indicator-team/+archive/ppa

Download full text (3.4 KiB)

Hi,
I am unable to add the ppa.I am getting this error.

-------------------------------------------------------------------------------------------------------------------------------------------

varun@varun-AO532h:~$ sudo add-apt-repository ppa:weather-indicator-team/ppa
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py",
line 63, in run
    self.add_ppa_signing_key(self.ppa_path)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py",
line 79, in add_ppa_signing_key
    lp_page = urlopen(req).read()
  File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.7/urllib2.py", line 391, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 409, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 369, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/urllib2.py", line 1193, in https_open
    return self.do_open(httplib.HTTPSConnection, req)
  File "/usr/lib/python2.7/urllib2.py", line 1156, in do_open
    r = h.getresponse(buffering=True)
  File "/usr/lib/python2.7/httplib.py", line 1027, in getresponse
    response.begin()
  File "/usr/lib/python2.7/httplib.py", line 407, in begin
    version, status, reason = self._read_status()
  File "/usr/lib/python2.7/httplib.py", line 371, in _read_status
    raise BadStatusLine(line)
BadStatusLine: ''

----------------------------------------------------------------------------------------------------------------------------------------

On 5/4/11, Panagiotis Skintzos <email address hidden> wrote:
> For the people still experiencing the problem:
> This issue has been fixed in the version included in the PPA:
> https://launchpad.net/~weather-indicator-team/+archive/ppa
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (774103).
> https://bugs.launchpad.net/bugs/733760
>
> Title:
> indicator-weather crashed with KeyError in save_location_details():
> 'yahoo id'
>
> Status in Indicator-Weather:
> Fix Released
>
> Bug description:
> cannot add "Senica city"
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: indicator-weather 11.02.13+unstable+bzr204~natty1
> ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
> Uname: Linux 2.6.38-6-generic x86_64
> Architecture: amd64
> CrashDB: indicator_weather
> Date: Sat Mar 12 11:13:43 2011
> ExecutablePath: /usr/bin/indicator-weather
> InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64
> (20100816.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
> ProcEnviron:
> LANGUAGE=sk_SK:sk_SK.UTF-8:sk:en_GB:en
> LANG=sk_SK.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/indicator-weather']
> SourcePackage: indicator-weather
> ThirdParty: True
> Title: indicator-weather crashed with KeyError in save_location_details():
> 'yahoo id'
> ...

Read more...

varun kumar (varunkumar-eie) wrote :
Download full text (3.8 KiB)

Hi,

Sorry for that,I got it..I forgot,i just removed the weather
indicator,since it is not showing weather in my place..I installed it
again and added the ppa.Now i got it.

Sorry once again

On 5/4/11, varun kumar <email address hidden> wrote:
> Hi,
> I am unable to add the ppa.I am getting this error.
>
> -------------------------------------------------------------------------------------------------------------------------------------------
>
>
> varun@varun-AO532h:~$ sudo add-apt-repository
> ppa:weather-indicator-team/ppa
> Exception in thread Thread-1:
> Traceback (most recent call last):
> File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
> self.run()
> File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py",
> line 63, in run
> self.add_ppa_signing_key(self.ppa_path)
> File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py",
> line 79, in add_ppa_signing_key
> lp_page = urlopen(req).read()
> File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
> return _opener.open(url, data, timeout)
> File "/usr/lib/python2.7/urllib2.py", line 391, in open
> response = self._open(req, data)
> File "/usr/lib/python2.7/urllib2.py", line 409, in _open
> '_open', req)
> File "/usr/lib/python2.7/urllib2.py", line 369, in _call_chain
> result = func(*args)
> File "/usr/lib/python2.7/urllib2.py", line 1193, in https_open
> return self.do_open(httplib.HTTPSConnection, req)
> File "/usr/lib/python2.7/urllib2.py", line 1156, in do_open
> r = h.getresponse(buffering=True)
> File "/usr/lib/python2.7/httplib.py", line 1027, in getresponse
> response.begin()
> File "/usr/lib/python2.7/httplib.py", line 407, in begin
> version, status, reason = self._read_status()
> File "/usr/lib/python2.7/httplib.py", line 371, in _read_status
> raise BadStatusLine(line)
> BadStatusLine: ''
>
> ----------------------------------------------------------------------------------------------------------------------------------------
>
> On 5/4/11, Panagiotis Skintzos <email address hidden> wrote:
>> For the people still experiencing the problem:
>> This issue has been fixed in the version included in the PPA:
>> https://launchpad.net/~weather-indicator-team/+archive/ppa
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug (774103).
>> https://bugs.launchpad.net/bugs/733760
>>
>> Title:
>> indicator-weather crashed with KeyError in save_location_details():
>> 'yahoo id'
>>
>> Status in Indicator-Weather:
>> Fix Released
>>
>> Bug description:
>> cannot add "Senica city"
>>
>> ProblemType: Crash
>> DistroRelease: Ubuntu 11.04
>> Package: indicator-weather 11.02.13+unstable+bzr204~natty1
>> ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
>> Uname: Linux 2.6.38-6-generic x86_64
>> Architecture: amd64
>> CrashDB: indicator_weather
>> Date: Sat Mar 12 11:13:43 2011
>> ExecutablePath: /usr/bin/indicator-weather
>> InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64
>> (20100816.1)
>> InterpreterPath: /usr/bin/python2.7
>> PackageArchitecture: all
>> P...

Read more...

Jiri Vaclavovic (jvaclavovic) wrote :

Version from ppa works for me (Plzeň, Czech Rep.). Thanks

varun kumar (varunkumar-eie) wrote :

Hmm,Not working me..My Update Manager kept up upgrading the
indicator-weather..Dont know why..My location is kadapa,Andhra
Pradesh,India.

Tried Both Google and Yahoo Server's.

On 5/4/11, Jiri Vaclavovic <email address hidden> wrote:
> Version from ppa works for me (Plzeň, Czech Rep.). Thanks
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (774105).
> https://bugs.launchpad.net/bugs/733760
>
> Title:
> indicator-weather crashed with KeyError in save_location_details():
> 'yahoo id'
>
> Status in Indicator-Weather:
> Fix Released
>
> Bug description:
> cannot add "Senica city"
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: indicator-weather 11.02.13+unstable+bzr204~natty1
> ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
> Uname: Linux 2.6.38-6-generic x86_64
> Architecture: amd64
> CrashDB: indicator_weather
> Date: Sat Mar 12 11:13:43 2011
> ExecutablePath: /usr/bin/indicator-weather
> InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64
> (20100816.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
> ProcEnviron:
> LANGUAGE=sk_SK:sk_SK.UTF-8:sk:en_GB:en
> LANG=sk_SK.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/indicator-weather']
> SourcePackage: indicator-weather
> ThirdParty: True
> Title: indicator-weather crashed with KeyError in save_location_details():
> 'yahoo id'
> UpgradeStatus: Upgraded to natty on 2011-02-19 (21 days ago)
> UserGroups: adm cdrom dialout dip fax floppy fuse plugdev sambashare tape
> video
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/weather-indicator/+bug/733760/+subscribe
>

Panagiotis Skintzos (ph7) wrote :

>
> Hmm,Not working me..My Update Manager kept up upgrading the
> indicator-weather..Dont know why..My location is kadapa,Andhra
> Pradesh,India.
>
> I tried your location and I see that there is not coverage (Yahoo does not
provide it and Google report is empty).
I can only recommend to try with a bigger city near by.

varun kumar (varunkumar-eie) wrote :

Ok..The Thing is when i click on the forecast,i am getting the
forecast correctly,but why it is not displaying temperature on the
panel..I think if it is displaying in the forecast,it has to be
displayed in the panel also

On 5/4/11, Panagiotis Skintzos <email address hidden> wrote:
>>
>> Hmm,Not working me..My Update Manager kept up upgrading the
>> indicator-weather..Dont know why..My location is kadapa,Andhra
>> Pradesh,India.
>>
>> I tried your location and I see that there is not coverage (Yahoo does not
> provide it and Google report is empty).
> I can only recommend to try with a bigger city near by.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (774105).
> https://bugs.launchpad.net/bugs/733760
>
> Title:
> indicator-weather crashed with KeyError in save_location_details():
> 'yahoo id'
>
> Status in Indicator-Weather:
> Fix Released
>
> Bug description:
> cannot add "Senica city"
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: indicator-weather 11.02.13+unstable+bzr204~natty1
> ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
> Uname: Linux 2.6.38-6-generic x86_64
> Architecture: amd64
> CrashDB: indicator_weather
> Date: Sat Mar 12 11:13:43 2011
> ExecutablePath: /usr/bin/indicator-weather
> InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64
> (20100816.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
> ProcEnviron:
> LANGUAGE=sk_SK:sk_SK.UTF-8:sk:en_GB:en
> LANG=sk_SK.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/indicator-weather']
> SourcePackage: indicator-weather
> ThirdParty: True
> Title: indicator-weather crashed with KeyError in save_location_details():
> 'yahoo id'
> UpgradeStatus: Upgraded to natty on 2011-02-19 (21 days ago)
> UserGroups: adm cdrom dialout dip fax floppy fuse plugdev sambashare tape
> video
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/weather-indicator/+bug/733760/+subscribe
>

Panagiotis Skintzos (ph7) wrote :

>
> Ok..The Thing is when i click on the forecast,i am getting the
> forecast correctly,but why it is not displaying temperature on the
> panel..I think if it is displaying in the forecast,it has to be
> displayed in the panel also
>
> The problem is in Google weather report, as the current conditions are
missing, but forecast is provided:
http://www.google.com/ig/api?weather=,,,14466667,78816667

I advice you to use the nearest city that works

Joey Dodson (ninjawailer) wrote :

I just upgraded using the ppa and this bug still affects me. I can't add Changsha, Hunan, China. When I try to apply the location nothing happens. I'm not sure if you call that a 'crash' as the app still keeps running.

Anyways, Los Angeles works fine, which is what I suppose I'll have to use until this is fixed. Changsha is the capital of Hunan Province, so there aren't any bigger cities reasonably close by.

Also I should note that Changsha does come up on the list when I search for it. It seems like Yahoo is what is holding this whole app back. Why not just totally remove Yahoo? Or at least have an option to disable Yahoo totally.

Panagiotis Skintzos (ph7) wrote :

Hi Joey,
I have successfully added Changsha, Hunan, China, in the latest ppa version.
Please attach the log file (~/cache/indicator-weather.log)
When a location is missing from Yahoo (as Changsha), Google is used, so it's
not really a problem.

Joey Dodson (ninjawailer) wrote :

Hmm, I just upgraded to Natty and am not super familiar with it yet. It does not seem to be able to find that .log file. Do you know the full directory in Ubuntu? I just tried again and it is definitely still not working. I should mention again, I'm not sure if this is a 'crash' exactly. I try to click the 'apply' button and nothing happens. The app keeps working otherwise though and I can still hit cancel, which successfully cancels the changes.

Panagiotis Skintzos (ph7) wrote :

It's in home folder under .cache subfolder

Joey Dodson (ninjawailer) wrote :

Ok, here it is.

It seems to show an error from Yahoo and then it says it adds the location, but it doesn't really do anything, so I end up having to cancel.

Gtmoraes1 (gtmoraes1) wrote :

I have an different issue - My city does show up on the search bar and I can add it to the list, but I won't receive any weather info. The weather-indicator orange icon sits there, idle. When I click to update, it shows "Update(Just now)" and after a minute, "Update(1 min. ago.)" and so on. I'm on Recife, capital of Pernambuco, Brasil. It's the biggest town I could use. I can get information on Yahoo! (http://br.tempo.yahoo.com/brasil/pernambuco/recife-26802900/) and on Google (http://www.google.com/ig/api?weather=Recife). The latter one shows the "city data" as one of the neighbourhoods (Recife Antigo), I don't know if this affects it.
If this makes any difference, I can still get weather info on Maverick'.

Vadim Rutkovsky (roignac) wrote :

Gtmoraes1, could you please post a screenshot of your issue and attach the log from ~/.cache/indicator-weather.log?

Gtmoraes1 (gtmoraes1) wrote :

Sure, here it goes

Screenshot here: http://i55.tinypic.com/2d95wcp.png
Log attached

Gtmoraes1 (gtmoraes1) wrote :

Oh sorry, forgot to say: I've tried several combinations to see if the program works, like adding New York (Nova Iorque, on the log), "Reef" (the word 'Recife', in english), 'Recife' in another state (which worked, but info doesn't match). I've settled down to my town around 5AM

Vadim Rutkovsky (roignac) wrote :

It seems, that you are affected by bug #776586

Gtmoraes1 (gtmoraes1) wrote :

Yup, it's this bug. I'll report from there now

Aleve Sicofante (sicofante) wrote :

Sorry for the duplicate post (I didn't see the duplication bug notice).

Happening here for two cities in Spain:

Vigo, Galicia, Spain
Santiago de Compostela, Galicia, Spain

PPA version.

Still having this problem

Still having this problem as of august 2011. i have two machines, same os, same app, different hardware. it does not work on the netbook, but it does work on my tower...??

please help!

Thanks. :)

sergey (ph4nt0m055) wrote :

Add this ppa and update to latest version
https://launchpad.net/~weather-indicator-team/+archive/ppa

I don't know why ubuntu doesn't update their packages. This should help.

Jaromir Obr (jaromir-obr) wrote :

Upgrade from 11.04 to 11.10 has solved this issue for me.
There is indicator-weather 11.05.31-0ubuntu2.1 which probably contains the fix.

There seems to be a regression as this doesn't work on the current 13.04 release...

Val (vk1266) wrote :

Apparently, Yahoo changed their GeoPlanet API and the old URL for resolving city names into WOEID now returns 404 Not Found. Therefore, this is not a regression in 13.04 -- this problem affects all users of indicator-weather.

I am looking into the new Yahoo API - hopefully, there is an easy way to fix the problem.

It also affects 12.04 LTS, but like you said "this problem affects all users of indicator-weather."

Val (vk1266) wrote :

There has been a flurry of activity at indicator-weather ppa in the past two weeks thanks to some new members in the project team:
https://launchpad.net/weather-indicator/

Apparently, the current version 13.05.27 no longer suffers from the WOEID 404 Not Found problem. The new version requires pywapi v.3, which must be installed alongside indicator-weather. It appears that pywapi v.3 has not yet been pushed to the standard repositories for 12.04 LTS and 13.04; therefore, Precise and Raring users must add the pywapi ppa manually. It looks like Quantal users already have pywapi v.3 in the standard Ubuntu repos.

Steve (ubuntustephen) wrote :

Hi All,

I am pretty new to Ubuntu and I just installed indicator-weather. I am having a problem running the "Setup".

When I open the setup and try to change anything, the "OK" button is never enabled. When I try to setup the location, the "Next" button is never enabled. I had entered a zipcode and the address is displayed and selected it. The spinning search icon, above the search button, just keeps spinning.

Can anyone help me with this problem?

(I attached the log file)

Thanks,
Steve

To post a comment you must log in.