Weather Indicator should have a Quit menu entry

Bug #703838 reported by Vadim Rutkovsky on 2011-01-17
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Wishlist
Vadim Rutkovsky

Bug Description

Indicator at any state should have a Quit menu

Changed in weather-indicator:
importance: Undecided → Wishlist
milestone: none → 11.02.16
status: New → Confirmed
Vadim Rutkovsky (roignac) wrote :

Call for testers - see Unstable Builds PPA in Weather Indicator Team (https://launchpad.net/~weather-indicator-team/+archive/unstable) for updated packages

Changed in weather-indicator:
assignee: nobody → Vadim Rutkovsky (roignac)
status: Confirmed → Fix Committed
charly (charlymr) wrote :

I tried the unstable ppa on my netbook (UNE 10.10), but it didn't work at all.
No icon is shown, so I could do nothing.

Vadim Rutkovsky (roignac) wrote :

My fault, I forgot to add, that citites are stored on other format.

Please, do the following - start gconf-editor, navigate to "/apps/indicator-weathe" and reset "places" setting. You will have to add citites again

Weather Indicator now logs some debug data to console - please, attach the ouptu if any error occurs

charly (charlymr) wrote :

Okay I tried it a second time, and reseted (deleted everything in this line and closed the gconf-editor) the "places".

But it didn't help, there is still nothing shown in the indicators place. So I tried to install the stable version again - but still nothing is happening.

Here is the error-report from the terminal:

.......1015PEM:~$ indicator-weather
Traceback (most recent call last):
  File "/usr/bin/indicator-weather", line 946, in <module>
    wi = indicator_weather()
  File "/usr/bin/indicator-weather", line 94, in __init__
    self.places = eval(self.places)
  File "<string>", line 0

    ^
SyntaxError: unexpected EOF while parsing

I hope this helps.

Vadim Rutkovsky (roignac) wrote :

Could you please show the output for the following command:
     apt-cache show indicator-weather | grep Version

Please, make sure that you have updated Weather Indicator from unstable PPA.

charly (charlymr) wrote :

Okay I installed the unstable version again and did as you requested:

....1015PEM:~$ apt-cache show indicator-weather | grep Version
Version: 11.01.16+bzr111~maverick1
Python-Version: 2.6

That's the result.

charly (charlymr) wrote :

I checked again for the error-message, now with the unstable version (as mentioned above), and got this result.

...1015PEM:~$ indicator-weather
Traceback (most recent call last):
  File "/usr/bin/indicator-weather", line 1122, in <module>
    wi = indicator_weather()
  File "/usr/bin/indicator-weather", line 428, in __init__
    self.places = eval(self.places)
  File "<string>", line 0

    ^
SyntaxError: unexpected EOF while parsing

OK, pushed a simple fix for empty places string. But, the idea was not
making it empty, but resettings it (right click - something like "reset
value")

charly (charlymr) wrote :

Sorry, looks like I'm too stupid.

I made the update and tried it again, but -

...1015PEM:~$ indicator-weather
Traceback (most recent call last):
  File "/usr/bin/indicator-weather", line 42, in <module>
    import gtkcrashhandler
ImportError: No module named gtkcrashhandler

Vadim Rutkovsky (roignac) wrote :

Thanks, charly, this actually was a bug #706796

charly (charlymr) wrote :

Thanks, vadim, now it works, I only can't choose a city. It always jumps back to the "enter city" field.

Changed in weather-indicator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions