weather applet crashs when setting location

Bug #1289824 reported by zEn
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Weather Indicator
New
Undecided
Unassigned

Bug Description

When clicking on apply after finding a City. It just seems to do nothing.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: indicator-weather 12.07.30-0ubuntu5 [origin: unknown]
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Uname: Linux 3.13.0-16-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CrashDB: indicator_weather
CurrentDesktop: Unity
Date: Sat Mar 8 02:18:53 2014
InstallationDate: Installed on 2011-11-08 (850 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
SourcePackage: indicator-weather
ThirdParty: True
UpgradeStatus: Upgraded to trusty on 2013-12-10 (87 days ago)

Revision history for this message
zEn (der-eremit) wrote :
Revision history for this message
John Hart (jlhart68) wrote :

I have found this to be true with both 32-bit OS and 64-bit OS, in both cases I get a notice that Ubuntu has had an internal error and nothing happens on the location addition.

I think the Weather Applet is borken and it affects the operating system adveersly.

I am using Ubuntu 12.04LTS on three computers and have the same problem with Weather Applet on all three.

Revision history for this message
Mikhail Veygman (mveygman) wrote :

There seems to be a field missing but still being used which is a result of reuse of old code or unintended consequence of a rewrite:

When trying to apply the location to the indicator-weather on Precise the following error occurs:

Traceback (most recent call last):
  File "/usr/bin/indicator-weather", line 1883, in on_apply
    (location_code, location_details) = self.location.export_location_details()
  File "/usr/bin/indicator-weather", line 405, in export_location_details
    return (self.location_code, self.location_details)
AttributeError: Location instance has no attribute 'location_code'

There is no attribute location_code within the class Location

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers