Menu not displaying most options in 13.10

Bug #1243857 reported by DK
114
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Critical
Joshua Tasker

Bug Description

Please see attached image

Revision history for this message
DK (dkretz) wrote :
Revision history for this message
Soonkee (1kc-ubuntu-hrz) wrote :

It seems a temporary solution has been posted (see related questions). Have not tried it though.

cheers,
monk

Revision history for this message
eaut (eaut) wrote :

my solution to it below:

--- /usr/bin/indicator-weather 2013-11-01 21:50:17.300149967 +0100
+++ indicator-weather-fix 2013-11-03 13:28:57.294192026 +0100
@@ -1862,7 +1862,6 @@
         quit.show()
         self.menu.append(quit)

- self.winder.set_menu(self.menu)
         self.update_label(" ")

     def menu_locations(self):
@@ -2093,6 +2092,8 @@

             self.update_label(cached_weather['label'])

+ self.winder.set_menu(self.menu)
+
         except Exception as e:
             log.error(e)
             log.debug(traceback.format_exc(e))

Revision history for this message
DK (dkretz) wrote :

Thanks eaut. I've applied but still get some crashes in 13.10.

Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

For me it just doesn't work on saucy even with the workaround described in related question.

Changed in weather-indicator:
status: New → Confirmed
Revision history for this message
Shock (mmiron) wrote :

Eaut's solution worked for me. Thank you eaut!

Revision history for this message
Vladimir Mencl (vladimir-mencl) wrote :

Also affects me. And this fix also works for me. (Ubuntu 13.10 x86_64, version 13.7.1 installed on 2013-11-18)

Revision history for this message
Joshua Tasker (jtasker) wrote :

Something was changed in GTK with the release of Saucy (13.10), such that creating a menu item without specifying a non-empty string for the label makes it so that later calls to set_label have no effect.

The fix mentioned in the attached question ( https://answers.launchpad.net/weather-indicator/+question/237754 ) works., this fix will be in the next release.

Changed in weather-indicator:
importance: Undecided → Critical
status: Confirmed → Triaged
assignee: nobody → Joshua Tasker (jtasker)
milestone: none → 13.8.0
Joshua Tasker (jtasker)
Changed in weather-indicator:
status: Triaged → Fix Released
Revision history for this message
Damon Hartman (area51pilot) wrote :

Thx ... just installed 13.8.0 'Rainy 8' on Ubuntu 13.10 x64 and confirm all items work. This is by far my favorite wx indicator! Accuracy and not being restricted to the amount of locations I can store is the deal maker for me. Again ... thx for your work.

Revision history for this message
Alexey Kulik (doctor-rover) wrote :

I also confirm fixing of the bug (Ubuntu 13.10 x64). Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions