Crash when adding first location to list (indicator-weather crashed with ValueError in ok(): None is not in list)

Bug #1234529 reported by Jos Geluk
720
This bug affects 164 people
Affects Status Importance Assigned to Milestone
Weather Indicator
High
Joshua Tasker
indicator-weather (Ubuntu)
Medium
Unassigned

Bug Description

Started indicator-weather for the first time; entered location and changed wind speed unit to m/s. Repeatable.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: indicator-weather 13.7.1 [origin: LP-PPA-weather-indicator-team]
ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
Uname: Linux 3.11.0-11-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
CrashDB: indicator_weather
Date: Thu Oct 3 08:26:50 2013
ExecutablePath: /usr/bin/indicator-weather
InstallationDate: Installed on 2013-09-29 (3 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Beta amd64+mac (20130925.1)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
PythonArgs: ['/usr/bin/indicator-weather']
SourcePackage: indicator-weather
ThirdParty: True
Title: indicator-weather crashed with ValueError in ok(): None is not in list
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/indicator-weather", line 2552, in ok
     wi.placechosen = wi.places.index(wi.place)
 ValueError: None is not in list
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip fuse lpadmin plugdev sambashare sudo

Revision history for this message
Jos Geluk (t-jos) wrote :
information type: Private → Public
Joshua Tasker (jtasker)
Changed in weather-indicator:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Joshua Tasker (jtasker)
milestone: none → 13.7.2
Revision history for this message
Joshua Tasker (jtasker) wrote :

This is fixed in the next unstable build, until then, here is a patch to fix the issue.

summary: - indicator-weather crashed with ValueError in ok(): None is not in list
+ Crash when adding first location to list (indicator-weather crashed with
+ ValueError in ok(): None is not in list)
Joshua Tasker (jtasker)
Changed in weather-indicator:
status: Triaged → Fix Committed
tags: added: precise
Islam Shoman (thetsar1)
Changed in weather-indicator:
status: Fix Committed → Fix Released
Revision history for this message
Joshua Tasker (jtasker) wrote :

Do not change the status to "Fix Released" unless the fix has actually been released in the latest RELEASE build. Unstable builds are not Release builds!

Changed in weather-indicator:
status: Fix Released → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
affects: ubuntu → indicator-weather (Ubuntu)
Changed in indicator-weather (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check
Changed in indicator-weather (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "lp1234529.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in weather-indicator:
status: Fix Committed → Fix Released
Joshua Tasker (jtasker)
Changed in weather-indicator:
milestone: 13.7.2 → 13.8.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers