Zone migration strategy scenario test error

Bug #1799435 reported by Hidekazu Nakamura on 2018-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
watcher
Undecided
Unassigned

Bug Description

Traceback (most recent call last):
  File "/opt/stack/tempest/.tox/tempest/local/lib/python2.7/site-packages/watcher_tempest_plugin/tests/scenario/test_execute_zone_migration.py", line 84, in test_execute_zone_migration_live_migration
    audit_template['uuid'], parameters=audit_parameters)
  File "/opt/stack/tempest/.tox/tempest/local/lib/python2.7/site-packages/watcher_tempest_plugin/tests/scenario/base.py", line 357, in create_audit
    state=state, interval=interval, parameters=parameters)
  File "/opt/stack/tempest/.tox/tempest/local/lib/python2.7/site-packages/watcher_tempest_plugin/services/base.py", line 38, in wrapper
    return f(*args, **kwargs)
  File "/opt/stack/tempest/.tox/tempest/local/lib/python2.7/site-packages/watcher_tempest_plugin/services/infra_optim/v1/json/client.py", line 139, in create_audit
    return self._create_request('audits', audit)
  File "/opt/stack/tempest/.tox/tempest/local/lib/python2.7/site-packages/watcher_tempest_plugin/services/base.py", line 152, in _create_request
    resp, body = self.post(uri, body=body, headers=headers)
  File "tempest/lib/common/rest_client.py", line 280, in post
    return self.request('POST', url, extra_headers, headers, body, chunked)
  File "tempest/lib/common/rest_client.py", line 676, in request
    self._error_checker(resp, resp_body)
  File "tempest/lib/common/rest_client.py", line 853, in _error_checker
    message=message)
tempest.lib.exceptions.ServerFault: Got server fault
Details: {"error_message": "{\"debuginfo\": null, \"faultcode\": \"Server\", \"faultstring\": \"None is not of type u'string'\\n\\nFailed validating u'type' in schema[u'properties'][u'compute_nodes'][u'items'][u'properties'][u'src_node']:\\n {u'description': u'Compute node from which instances migrate',\\n u'type': u'string'}\\n\\nOn instance[u'compute_nodes'][0][u'src_node']:\\n None\"}"}

This issue was fixed in the openstack/watcher-tempest-plugin 1.1.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers