can not start the decision-engine due to bad goal name

Bug #1602262 reported by David TARDIVEL on 2016-07-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
watcher
Critical
David TARDIVEL

Bug Description

# Pastebin 0jRIyX9E
2016-07-12 13:17:14.905 CRITICAL python-watcher [req-456697a1-6ada-4507-a6c1-bd74344ed690 ] GoalNotFound: Goal airflow_optimization could not be found

2016-07-12 13:17:14.905 TRACE python-watcher Traceback (most recent call last):
2016-07-12 13:17:14.905 TRACE python-watcher File "/usr/local/bin/watcher-decision-engine", line 10, in <module>
2016-07-12 13:17:14.905 TRACE python-watcher sys.exit(main())
2016-07-12 13:17:14.905 TRACE python-watcher File "/opt/stack/watcher/watcher/cmd/decisionengine.py", line 43, in main
2016-07-12 13:17:14.905 TRACE python-watcher syncer.sync()
2016-07-12 13:17:14.905 TRACE python-watcher File "/opt/stack/watcher/watcher/decision_engine/sync.py", line 119, in sync
2016-07-12 13:17:14.905 TRACE python-watcher self.strategy_mapping.update(self._sync_strategy(strategy_map))
2016-07-12 13:17:14.905 TRACE python-watcher File "/opt/stack/watcher/watcher/decision_engine/sync.py", line 167, in _sync_strategy
2016-07-12 13:17:14.905 TRACE python-watcher strategy.goal_id = objects.Goal.get_by_name(self.ctx, goal_name).id
2016-07-12 13:17:14.905 TRACE python-watcher File "/opt/stack/watcher/watcher/objects/goal.py", line 116, in get_by_name
2016-07-12 13:17:14.905 TRACE python-watcher db_goal = cls.dbapi.get_goal_by_name(context, name)
2016-07-12 13:17:14.905 TRACE python-watcher File "/opt/stack/watcher/watcher/db/sqlalchemy/api.py", line 432, in get_goal_by_name
2016-07-12 13:17:14.905 TRACE python-watcher return self._get_goal(context, fieldname="name", value=goal_name)
2016-07-12 13:17:14.905 TRACE python-watcher File "/opt/stack/watcher/watcher/db/sqlalchemy/api.py", line 423, in _get_goal
2016-07-12 13:17:14.905 TRACE python-watcher raise exception.GoalNotFound(goal=value)
2016-07-12 13:17:14.905 TRACE python-watcher GoalNotFound: Goal airflow_optimization could not be found
2016-07-12 13:17:14.905 TRACE python-watcher

summary: - can not stat the decision-engine due to bad goal name
+ can not start the decision-engine due to bad goal name

Fix proposed to branch: master
Review: https://review.openstack.org/340946

Changed in watcher:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/340946
Committed: https://git.openstack.org/cgit/openstack/watcher/commit/?id=517f1d083ecee4ac6849b3bf81d1f474715e40cc
Submitter: Jenkins
Branch: master

commit 517f1d083ecee4ac6849b3bf81d1f474715e40cc
Author: David TARDIVEL <email address hidden>
Date: Tue Jul 12 15:32:29 2016 +0200

    Bad goal and strategy name for Airflow Optimization

    The goal name 'airflow optimization' must be synched with the
    entry point name.
    The strategy name 'uniform airflow' must be synched with the
    entry point name.

    Partial-Bug: #1602262

    Change-Id: Ibc6f0a7c5047e57549910818200c323b878152b0

Reviewed: https://review.openstack.org/340985
Committed: https://git.openstack.org/cgit/openstack/watcher/commit/?id=a68eb0d619ca1712300fab9d756954834accbf74
Submitter: Jenkins
Branch: master

commit a68eb0d619ca1712300fab9d756954834accbf74
Author: David TARDIVEL <email address hidden>
Date: Tue Jul 12 16:54:38 2016 +0200

    Update unitaty tests to verify strategy and goal name

    strategy and goal name must be synched with entry point names.

    Change-Id: I776ed98f5c13d176fdb0b8677d609fcb1ec9a235
    Closes-Bug: #1602262

Changed in watcher:
status: In Progress → Fix Released

This issue was fixed in the openstack/watcher 0.28.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers