i18n - Lazy translation unsupported by watcher-db-manage

Bug #1584652 reported by Vincent Françoise on 2016-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
watcher
Critical
Vincent Françoise

Bug Description

The watcher-db-manage command currently does not support the lazy translation. Since python-cinderclient now uses the graduated oslo_i18n lib, we now have most of the unit tests related to this command fail.

Fix: Make sure the headers are translated before passing them to the prettytable lib (which does not handle it).

Changed in watcher:
importance: Undecided → Critical

Fix proposed to branch: master
Review: https://review.openstack.org/319777

Changed in watcher:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/319777
Committed: https://git.openstack.org/cgit/openstack/watcher/commit/?id=277a749ca0887819048ae1892b0dfa543bf30d30
Submitter: Jenkins
Branch: master

commit 277a749ca0887819048ae1892b0dfa543bf30d30
Author: Vincent Françoise <email address hidden>
Date: Mon May 23 10:44:01 2016 +0200

    Fix lazy translation issue with watcher-db-manage

    In this changeset, I fix the issue caused by the use of lazy
    translations within the 'watcher-db-manage purge' subcommand.
    This is caused by the PrettyTable dependency which performs
    addition operations to format its tables and the __add__ magic
    method is not supported by oslo_i18n._message.Message objects.

    Change-Id: Idd590e882c697957cfaf1849c3d51b52797230f6
    Closes-Bug: #1584652

Changed in watcher:
status: In Progress → Fix Released

This issue was fixed in the openstack/watcher 0.27.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers