HTTPS not mentioned if CONF.api.enable_ssl_api is True

Bug #1580044 reported by Vincent Françoise on 2016-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
watcher
Low
Yosef Hoffman

Bug Description

When starting the Watcher API service, the URI it served to is shown in a log message. However, this log message (in watcher/cmd/api.py) does not take into account the case where SSL has been enabled with CONF.api.enable_ssl_api set to "True". Hence we should format this log message accordingly.

Changed in watcher:
importance: Undecided → Low
Changed in watcher:
assignee: nobody → Yosef Hoffman (yh128t)

Fix proposed to branch: master
Review: https://review.openstack.org/314610

Changed in watcher:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/314610
Committed: https://git.openstack.org/cgit/openstack/watcher/commit/?id=76e3d2e2f6c09e19f748971d509937b64cf46f45
Submitter: Jenkins
Branch: master

commit 76e3d2e2f6c09e19f748971d509937b64cf46f45
Author: Yosef Hoffman <email address hidden>
Date: Tue May 10 11:44:56 2016 -0400

    Log "https" if using SSL

    When starting the Watcher API service, the URI it served to is shown in
    a log message. In this log message (in watcher/cmd/api.py) take into
    account the case where SSL has been enabled with CONF.api.enable_ssl_api
    set to True and format this log message accordingly.

    Change-Id: I98541810139d9d4319ac89f21a5e0bc25454ee62
    Closes-Bug: #1580044

Changed in watcher:
status: In Progress → Fix Released
Changed in watcher:
milestone: none → newton-1

This issue was fixed in the openstack/watcher 0.27.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers