instanciation of the ceilometer client fails

Bug #1544652 reported by David TARDIVEL on 2016-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
watcher
High
Vincent Françoise

Bug Description

When I run basic-consolidation tempest test, I have this error:

2016-02-11 16:09:08.208 DEBUG watcher.common.loader.default [req-4c42c898-8efc-4833-8472-5995cf602e54
  ] Loading in namespace watcher_strategies => basic from (pid=8006) load /
opt/stack/watcher/watcher/common/loader/default.py:36
2016-02-11 16:09:08.240 INFO watcher.decision_engine.strategy.strategies.basic_consolidation [req-4c4
2c898-8efc-4833-8472-5995cf602e54 ] Initializing Sercon Consolidation
2016-02-11 16:09:08.259 ERROR watcher.decision_engine.audit.default [req-4c42c898-8efc-4833-8472-5995
cf602e54 ] get_auth_plugin() takes exactly 1 argument (0 given)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default Traceback (most recent call l
ast):
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/decision_engine/audit/default.py", line 77, in execute
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default request_context)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/decision_engine/strategy/context/default.py", line 64, in execute_strategy
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default return selected_strategy.
execute(cluster_data_model)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/decision_engine/strategy/strategies/basic_consolidation.py", line 462, in execute
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default score = self.score_of_nod
es(current_model, score)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/decision_engine/strategy/strategies/basic_consolidation.py", line 357, in score_of_nodes
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default result = self.calculate_s
core_node(hypervisor, current_model)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/decision_engine/strategy/strategies/basic_consolidation.py", line 261, in calculate_score_node
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default cpu_avg_vm = self.ceilome
ter. \
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/decision_engine/strategy/strategies/basic_consolidation.py", line 107, in ceilometer
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default self._ceilometer = Ceilom
eterClusterHistory(osc=self.osc)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/metrics_engine/cluster_history/ceilometer.py", line 35, in __init__
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default self.ceilometer = ceilome
ter_helper.CeilometerHelper(osc=osc)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/common/ceilometer_helper.py", line 29, in __init__
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default self.ceilometer = self.os
c.ceilometer()
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/common/exception.py", line 52, in wrapped
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default return func(*args, **kw)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/opt/stack/watcher/wa
tcher/common/clients.py", line 145, in ceilometer
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default session=self.session)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/usr/local/lib/python
2.7/dist-packages/ceilometerclient/client.py", line 366, in Client
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default return client_class(*args
, **client_kwargs)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default File "/usr/local/lib/python
2.7/dist-packages/ceilometerclient/v2/client.py", line 62, in __init__
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default **kwargs)
2016-02-11 16:09:08.259 TRACE watcher.decision_engine.audit.default TypeError: get_auth_plugin()
takes exactly 1 argument (0 given)

Watcher can not successfully instantiate the ceilometer client

Changed in watcher:
assignee: nobody → Vincent Françoise (vincent-francoise)
status: New → Confirmed
status: Confirmed → In Progress
importance: Undecided → High
milestone: none → mitaka-3

Reviewed: https://review.openstack.org/279200
Committed: https://git.openstack.org/cgit/openstack/watcher/commit/?id=b958214db832b5ee8849017efa18e7aca4007bd1
Submitter: Jenkins
Branch: master

commit b958214db832b5ee8849017efa18e7aca4007bd1
Author: Vincent Françoise <email address hidden>
Date: Thu Feb 11 18:26:44 2016 +0100

    Ceilometer client instantiation fixup

    A problem was found during manual integration tests which were failing
    because we couldn't instantiate the ceilometer client when trying to
    execute an action plan using the 'basic_consolidation' strategy.

    This patchset fixes the problem with an update of the related tests

    Change-Id: I2b1f1dcc16fd8dfbf508c4d5661c1fce194254e4
    Closes-Bug: #1544652

Changed in watcher:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers