API - Trying to fetch an already deleted Audit Template with 500 as status code

Bug #1531877 reported by Vincent Françoise on 2016-01-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
watcher
Medium
Vincent Françoise

Bug Description

When trying to retrieve an Audit Template which either does not exist at all or got previously deleted, we get a misleading status code. As the resource dos not exist, one would expect to have a 404 status code instead of a 500 status code as it is currently the case.

So the objective is to return a 404 NOT FOUND in this scenario. Also, the correct/specific exception should be raised, i.e. AuditTemplateNotFound.

tags: added: api
Changed in watcher:
status: New → Confirmed
Changed in watcher:
importance: Undecided → Medium

Well it's kind of the same but this one is about audit templates whereas the other one is about audits.
So they are very similar and it's likely that fixing one will fix the other but I'm not sure yet.

So IMHO, the best thing to do would be to link them together but I don't know how.

After switching to a fresh devstack environment, the problem wasn't there anymore. So I guess it was fixed along the way.

Changed in watcher:
status: Confirmed → Fix Released
Changed in watcher:
assignee: nobody → Vincent Françoise (vincent-francoise)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers