Use os-testr instead of testr

Bug #1525854 reported by Vincent Françoise on 2015-12-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
watcher
Wishlist
biswajeeban

Bug Description

Changed in watcher:
importance: Undecided → Low
Changed in watcher:
assignee: nobody → biswajeeban (biswajeeban)
biswajeeban (biswajeeban) wrote :

@Vincent: Should we just replace the string testr with ostestr or Is there any dependencies we need to take care of. Kindly provide bit more information.

You need to add the os-testr test dependency with regard to the sable/librety global requirements (see https://github.com/openstack/requirements/blob/stable/liberty/global-requirements.txt#L108).
Then yes, you can pretty much replace the 'testr' string by 'ostestr', plus you'll have to deal with any edge case which might occur.

Changed in watcher:
importance: Low → Wishlist
biswajeeban (biswajeeban) wrote :

tox test run failed - error: invalid command 'ostestr'

Hi Vincent,

Added os-testr test dependency with regard to the sable/librety global requirements in test-requirements.txt file. Modified Tox.ini to use os-testr instead of testr. Even then tox test run failed returning error: invalid command 'ostestr'. Is there anything else missing that could help resolve this issue.

Please have a look at the modifications here https://docs.google.com/document/d/1nZRO7rO6aYEBFCJoDHDJSOe0KBh-3TDNreHDvlYeQmw/edit

Hi,

Given what you just wrote, I would say that everything should work (I don't have access to your google doc yet). So my first guess would be that you didn't recreate your virtualenvs after adding this new requirement ($ tox -e py34,py27 --recreate).
Indeed, you might not be aware that tox does not recreate the whole venv unless told explicitly: it only reinstalls the package under test (i.e. watcher) which then means that your new requirement is missing although everything is correctly configured.

Anyhow, if you keep having issues on this, we can also discuss it on IRC (#openstack-watcher).

So I had a look at your google doc and the problem is that you are not using the command as it should.

You can take a look at https://review.openstack.org/#/c/186879/ to see how they use it. Also note that you currently can't use ostestr for the coverage so just leave it as is. To make it easier to review, please do push your patchset onto gerrit and put it on workflow -1 with myself as reviewer so I can comment on it (line by line) more efficiently ;)

Changed in watcher:
milestone: none → mitaka-2
status: New → In Progress

Reviewed: https://review.openstack.org/264784
Committed: https://git.openstack.org/cgit/openstack/watcher/commit/?id=9900273988aa36c1014b643846499fd7c8496df5
Submitter: Jenkins
Branch: master

commit 9900273988aa36c1014b643846499fd7c8496df5
Author: Biswajeeban Mishra <email address hidden>
Date: Thu Jan 7 14:32:06 2016 +0100

    Changed testr to os-testr

    Change-Id: I6dd478e3bac50cf5a2d0ad32af0e36c25c0df071
    Related-Bug: #1525854

Changed in watcher:
status: In Progress → Fix Committed
Changed in watcher:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers