Fix all uses of make-channel to make-queue

Bug #113397 reported by Scott W. Dunlop on 2007-05-08
2
Affects Status Importance Assigned to Milestone
WaspVM
High
Unassigned

Bug Description

With the removal of make-channel, and the reduction of <channel>, <input> and <output> to abstract base types, all uses of make-channel in legacy code must be replaced with uses of make-queue.

Be careful to also find any erroneous attempts to send data to a queue, directly, or wait on a queue.

Changed in waspvm:
importance: Undecided → High
status: Unconfirmed → Confirmed
Scott W. Dunlop (swdunlop) wrote :

For now, a multimethod implementation of the old send semantics can be placed in core/io. Ideally, all calls to send should be examined, as this will probably be a good indication of possible problems with the new channel semantics..

Ditto for the wait primitive, which is now wait-input.

Scott W. Dunlop (swdunlop) wrote :

This is no longer an issue due to core/io emulating the old semantics for the send and wait multimethod.

Changed in waspvm:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers