Lumber Gathering is Glitched

Bug #919792 reported by Enker-Zan on 2012-01-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Wargus
Fix Released
Undecided
Joris Dauphin

Bug Description

After using the fix method erstmap posted to make 2.2.6 work, It ran perfectly. However, I did a playtest and quickely discovered that the lumber gathering is not working properly at all. In the replay I have posted, watch the AI or me. Mainly watch the Peasants/Peons gather lumber for the AI. You will see that the workers are fidgeting in 1 spot for random extended periods of time after they turn in their 1st stack of 100 lumber.

I had to force each Peasant I owned to start gathering lumber manualy, clicking on the trees when they are far away does not do anything, they will still sit there. I had to physicaly move them right next to the tree to start chopping wood again. Then the process repeats to no end. After you tell a worker to gather lumber, and they turn in their 1st stack, their wood carry count is always at 0. It never goes away after that, even when telling the, to build a structure or to gather gold.

In the replay, the AI could not do anything to build their base because their Peons were glitching out. Which means this version needs an immidiate patch, AI like this is too easy to kill, hence it is no fun... However, can players with the expansion CD confirm that this is happening too? I have tried this on 3 different computers and got the same results.

- Original WarCraft 2 DOS CD (no expansion)
- stratagus version 2.2.6 (latest)
- Wargus version 2.2.6 (latest)
- Windows XP SP3

Revision history for this message
Enker-Zan (enkerzan) wrote :

I was gonna post the replay, but for whatever reason Wargus/Stratagus is not saving them even when I hit the save replay button myself. Gonna add this as a seperate bug report on the list...

Revision history for this message
Joris Dauphin (joris-dauphin) wrote :

bug with trees already fixed in trunk.

Changed in wargus:
status: New → Fix Released
Revision history for this message
yfm (you-fail-me) wrote :

I've experienced this bug too. What should I download and use to make it gone?

Revision history for this message
Joris Dauphin (joris-dauphin) wrote :

It has been fixed in trunk, but not yet released in official version
To use it, you have to get and compile stratagus trunk with wargus trunk.
Note that savegame/replay may be incompatible.

Changed in wargus:
milestone: none → 2.2.7
assignee: nobody → Joris Dauphin (joris-dauphin)
status: Fix Released → Fix Committed
Revision history for this message
yfm (you-fail-me) wrote :

Maybe, it could be released in a way of a patch, or an instruction of what data file should be changed and how?..
Because 2.2.7. version seems to be released not so soon, and this lumber bug makes 2.2.6. totally unplayable(

Revision history for this message
Kyran Jackson (erstmap) wrote :

/callvote release 2.2.7

Pali (pali) on 2012-08-20
Changed in wargus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers