invalid tile number: 80

Bug #736460 reported by vota on 2011-03-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Wargus
Fix Released
Undecided
Joris Dauphin

Bug Description

I get this error if I try to make a new map (I can create and save it, but when I try to load or edit again I get the error) and if I try to edit a campaign map.

Related branches

Kyran Jackson (erstmap) wrote :

This problem is caused by a tileset not being assigned. In the map file the editor puts:

LoadTileModels("")

This will crash the engine as it expects something like:

LoadTileModels("scripts/tilesets/winter.lua")

You can manually replace LoadTileModels("") with LoadTileModels("scripts/tilesets/winter.lua") in your map file to fix this error.

Changed in wargus:
importance: Undecided → High
importance: High → Undecided
status: New → Confirmed
Pali (pali) wrote :

Kyran, can you fix this bug?

Kyran Jackson (erstmap) wrote :

I've tried looking into it, though I haven't had any luck finding where the issue is. The tileset variable is set correctly in the editor because it loads, but it just doesn't seem to make it to the save function.

I don't think I'll be able to fix it any time soon. I haven't looked at it but I've got a hunch that the problem lies within the function that takes care of saving. At the very least that function should assign a default tileset if it doesn't get sent one.

Kyran Jackson (erstmap) wrote :

Player attributes are also not getting assigned. Such as the resource count and the player AI. This causes a crash with no error message.

This issue definitly wasn't present in 2.4, so it's caused by a recentish change.

Changed in wargus:
assignee: nobody → Joris Dauphin (joris-dauphin)
Pali (pali) wrote :
Changed in wargus:
status: Confirmed → Fix Committed
milestone: none → 2.2.6
Pali (pali) on 2011-12-26
Changed in wargus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers