there aren't cycles, and the icons don't change

Bug #619006 reported by german on 2010-08-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Wargus
Fix Released
Undecided
Joris Dauphin

Bug Description

hello, when i was playing the other day, i realized, that, in the new version, the cycles, like the water cycle in the pallete (38-47). the building cycles and the icons cycles, are disabled, in that sense, the game is very static. Also another bug i found, was the colors in the icons, as you can see, the icons do not change colors, when the player change. they are always in red color.

sorry if my english is not the best, in truth, i speak spanish =)

Pali (pali) wrote :

What do you mean with building or icons cycles? Sorry, but I dont now what do you mean. Can you explain it?
And in which version of stratagus/wargus was this working? And which version do you use now?

I mean that if you see the preview versions, like the 2.0, the cycles are
in, also in the orignal wacraft. For example, the cycles are basically, some
colors that changes constantly. this is used to give the effect of water
movement, i think. In warcraft palletes, the cycles are the colors that are
in the index 38 to 47. Also there are another cycle, a shorter one, that
start in the index 205 to 207, this cycle is appreciable in the winter
tileset, when you look buildings like the human church, in the Christmas
tree and in the goblin alchemist. And in the icons, when you play, the icons
do not change colors, always are in red color. In previews versions and in
the original warcraft, the icons change, when the player change, so, if you
are the blue player, the icons should be in blue color, not in red. And with
respect to the version that i use, I used the version 2.0 in which, I think,
was the most faithful to the real game. Now I use the latest version, the
2.2.5.3. Where all the little details were removed. Well I say goodbye,
anyway, good work that you have done!

2010/8/21 Pali <email address hidden>

> What do you mean with building or icons cycles? Sorry, but I dont now what
> do you mean. Can you explain it?
> And in which version of stratagus/wargus was this working? And which
> version do you use now?
>
> --
> there aren't cycles, and the icons don't change
> https://bugs.launchpad.net/bugs/619006
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Wargus - Warcraft II: New
>
> Bug description:
> hello, when i was playing the other day, i realized, that, in the new
> version, the cycles, like the water cycle in the pallete (38-47). the
> building cycles and the icons cycles, are disabled, in that sense, the game
> is very static. Also another bug i found, was the colors in the icons, as
> you can see, the icons do not change colors, when the player change. they
> are always in red color.
>
> sorry if my english is not the best, in truth, i speak spanish =)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/wargus/+bug/619006/+subscribe
>

Pali (pali) wrote :

Old Stratagus and Wargus version I found only here:
https://stratagus.svn.sourceforge.net/svnroot/stratagus/stratagus/tags/
https://wargus.svn.sourceforge.net/svnroot/wargus/tags/

Can you find out which version is last what has support for this?

And for pallets: can you tell me in which file and which index? 205-207 is wave sound for ogre acknowledgement.
See wartool.c where are all files (for extract from original WAR2 CD):
http://bazaar.launchpad.net/~stratagus/wargus/trunk/annotate/head:/wartool.c

Joris Dauphin (joris-dauphin) wrote :

From history :
Remove color cycling:
Stratagus : 6515 2005-04-30 jsalmon3
Wargus : 1055 2005-04-30 jsalmon3

Pali (pali) on 2010-11-13
Changed in wargus:
status: New → Confirmed
status: Confirmed → Triaged
assignee: nobody → Joris Dauphin (joris-dauphin)
Pali (pali) wrote :

Joris commited some patches which reverted color cycling support back. So this bug should be now fixed on bzr.

Changed in wargus:
status: Triaged → Fix Committed
milestone: none → 2.2.6
Pali (pali) on 2011-12-26
Changed in wargus:
status: Fix Committed → Fix Released

 http://itravellerindia.com/ajcpdl/udaxstwxl

 pepeelgranjero

 7/21/2013 4:46:24 PM

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers