Some cheats don't work

Bug #1162392 reported by EliCoten on 2013-03-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Wargus
Fix Released
Undecided
cybermind

Bug Description

For example, when I tried make it so, it didn't work.

In fact the only cheats that I could get to work were (though I'm not sure I tried all of them listed in https://github.com/realhidden/wargus/blob/master/scripts/cheats.lua):

glittering prizes
it is a good day to die
disco

I didn't try all of the others but the ones I did try didn't work.

Related branches

Joris Dauphin (joris-dauphin) wrote :

You can see cheat in wargus/scripts/cheats.lua

Note that cheats are enabled only in single player mode.

EliCoten (launchpad-elicoten) wrote :

Yes but they don't work even in single player mode.

David Jefferson (catcher-k) wrote :

After messing with wargus/scripts/cheats.lua, adding messages at various points, the following cheats do not work:

"hatchet": enters correct if statement, never returns from SetSpeedResourceHarvest
"normal debug" and "fast debug": enters loop, never completes iteration. SetSpeedResourceHarvest also suspect
"make it so": detects speedcheat flag, enters loops, never completes iteration. SetSpeedResourceHarvest also suspect
"fill mana": enters loop, never returns from SetUnitMana

Obviously "there is no aliens level" doesn't have a function, but it triggers the if statement and makes it to the return true. "disco" executes cleanly but I play with music off so I don't know if it works correctly.

Other tested cheats (all working): "glittering prizes", "on screen", "fow on", "fow off", "unite the clans", "you pitiful worm", "it is a good day to die".

It also successfully makes it to return false if you pass something that isn't listed.

Kyran Jackson (erstmap) wrote :

Debug cheat is fixed in the trunk.

cybermind (iddqd-mail) wrote :

Fixed in rev.1706

Changed in wargus:
status: New → Fix Committed
assignee: nobody → cybermind (iddqd-mail)
cybermind (iddqd-mail) on 2015-03-19
Changed in wargus:
status: Fix Committed → Fix Released
milestone: none → 2.3
mojucet666 (mojucet666) wrote :

I read "fix is released" but I don't understand...
I want to skip some campaign levels but it does not work. I have Warcraft II Wargus 2.3

How do I use other cheats like "Tigerlily" to jump levels ?
or "There can be only one" for campaign victory.
  I'm trying all googling, checking cheats.lua - it's not there.. why would you not enable some cheats whilst you did so amazing remake of whole game... ahh. So how to do it ???

mojucet666 (mojucet666) wrote :

oki I found out by myself. this should be full list of cheats available in Warcraft 2 Wargus:

hatchet
glittering prizes
on screen
showpath
fow on
fow off
fast debug
normal debug
make it so
unite the clans
you pitiful worm
it is a good day to die
fill mana
disco

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers